• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1900
  • Last Modified:

Live Meeting 2007 will not save settings.

This is an incredibly annoying issue.

I have Live Meeting installed on a client machine that runs Vista Enterprise. Our OCS / Live Meeting server is set up to use TLS instead of TCP. If I go in a users' Live Meeting settings and set their client to use TLS (default is TCP) the program works fine. If the user logs off and logs back in the settings revert back to TCP. Nothing I can do will get these settings to save.

If I log in under the DOMAIN\Administrator account and set that accounts settings, they save (but just for that admin user).

I tried adding the user to the local admin group on the machine in question, that didn't solve anything.
0
dfxdeimos
Asked:
dfxdeimos
  • 3
  • 3
1 Solution
 
gaanthonyCommented:
Communicator 2007 and Live Meeting 2007 use share client configurations which are stored in HKEY_CURRENT_USER\Software\Microsoft\Shared\UcClient.
This can be overriddeen via GPO settings which can be applied to the User or Local Computer registry context.
HKEY_LOCAL_MACHINE settings would take precedence over HKEY_CURRENT_USER.
0
 
dfxdeimosAuthor Commented:
If I log in as the affected user and change the HKEY_CURRENT_USER\Software\Microsoft\Shared\UcClient\Trasport value from 2 (TCP) to 1 (TLS) communicator works fine until I log off and log back at which time the changes are erased.

I was unable to find a UcClient key underneath the HKLM\Software\Microsoft\Shared so I don't see a way to set this option system wide.
0
 
gaanthonyCommented:
The UcClient key can be created under HKLM\Software\Microsoft\Shared if it doesn't exist.
Is this just happening to a particular user or all users?  If it's a particular user with a roaming profile I'd check that they have correct permissions to their roaming profile directory and that it's updating those changes in the roaming directory especially the ntuser.dat file.
 Are they any Communicator or Live Meeting .adm templates for GPO applied to Active Directory.  Run a Resultant Set of Policy (RSOP) on the user to see what is being applied by group policy.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
dfxdeimosAuthor Commented:
Ok, I created the key "UcClient" under the HKLM\Software\Microsoft\Shared and assigned it a value of 1 (TLS).

After logging in as the affected user I opened up Outlook and clicked in the Schedule Live Meeting button ( NOTE: I am paraphrasing all the setting names / dialouges because the OS is in German) on the Outlook Add-In. It presented me with a message that I had to configure the user setttings. Clicking OK opened up the settings window. I pressed the "Test Connection" button and it failed saying it couldn't communicate with the server.

I then clicked the Advanced button (where you specify TCP or TLS), noted that the setting was on TLS (instead of defaulting to TCP), didn't change anything, and clicked OK. Clicking "Test Connection" again presented the dialouge box that said it had successfully communicated with the server. Clicking OK closed the settings window for the Add-In. I could then click the Schedule Live Meeting button and the expected e-mail with the Live Meeting info popped up.

I logged off and logged back in, opened Outlook, and clicked on the Schedule Live Meeting button. I now recieved the same error message (translated... poorly):

"With the server can not connect because the information in the dialog box "user" potentially faulty or not ordnungsgemab formatted. Check whether the information is correct, and then click Test Connection. " If you still can not connect, the server is potentially not available"

I then went back into the add-in user setup page, clicked on advanced, now the transport mode is changed back to TCP from TLS. If I change it back, click OK, and click Test Connection it now works ok. That is, until I log off and back on... ad nauseum...

The same results happen if I change the Transport key under the HKCU hive to 1 instead of 2, it works for one session, but reverts back to 2 after I log off and back in.

The same results happen if I totally delete the transport key under the HKCU hive (under the assumption that it would recreate the settings based off of the "Trasport" value I set under the HKLM hive. When doing this though, after logging off and back in the Transport value is recreated under the HKCU hive with a value of 2 (the Transport under HKLM is set to 1).

There are no custom ADM files or GPOs being applied that have any settings related to Live Meeting (the GPO structure in this domain is very simple).

There is only one client on this domain (for testing purposes, Vista Enterprise x86) and all users on that client have the same issue... instant reversion from TLS to TCP regardless of how I set the settings.

As a last resort, and keeping in mind that security is not a concern in this domain, can I just enable TCP connections so that the server will accept the defaults if we cannot resolve this?

Thank you for your time.
0
 
gaanthonyCommented:
Looks like this article covers your issue.
http://support.microsoft.com/kb/950335
Download the latest Live Meeting client and Conferencing Add-in from http://office.microsoft.com/en-us/downloads/CD102549901033.aspx.
Download the latest Communicator 2007 update from
http://www.microsoft.com/downloads/details.aspx?FamilyID=1ad57f8f-78f7-45f6-a8c0-805936f46645&displaylang=en
 
0
 
dfxdeimosAuthor Commented:
Removing the Outlook Add-In and Live Meeting, cleaning up the registry entries associated with them, downloading the versions you pointed me to, and reinstalling them resolve the issue for me.

Thank you so much for your assistance.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now