Solved

Installing Lazarus on Linux X86/64bit

Posted on 2008-10-21
3
1,362 Views
Last Modified: 2013-11-11
When installing the rpm-package of Lazarus (version for X86/64) on a Linux system the following error message appears:

error: Failed dependencies:
fpc = 2.2.2-0 is needed by lazarus-0.9.26-0.x86_64
fpc-src=2.2.2-0 is needed by lazarus-0.9.26-0.x86_64
gdk-pixbuf is needed by lazarus-0.9.26-0.x86_64
gtk+ is needed by lazarus-0.9.26-0.x86_64
libgdk-1.2.so.0()(64bit) is needed by lazarus-0.9.26-0.x86_64
libgdk_pixbuf.so.2()(64bit) is needed by lazarus-0.9.26-0.x86_64
libglib-1.2.so.0()(64bit) is needed by lazarus-0.9.26-0.x86_64
libgtk-1.2.so0()(64bit) is needed by lazarus-0.9.26-0.x86_64

By the way, I typed in the following command:
rpm -ivh --force lazarus-0.9.26-0.x86_64.rpm

Could somebody please tell me what the above error message means. What can I do?
0
Comment
Question by:EXF_Pilatus
  • 2
3 Comments
 
LVL 28

Accepted Solution

by:
ciuly earned 500 total points
ID: 22774586
you need to also install those rpms'. best way is to download all and instal all from one line :)
fpc and fpc src you get from the same place as the lazarus rpm (I assume you downloaded it from sourceforge. if not, get them from there, including the lazarus rpm)
the rest depend on the specific packages. but as I see you need to install the gtk desktop with its development packages and I think that would take care of all. in case you do have the gtk desktop installed, then get your cd's and find those packages there and install them manually. those packages might depend on others. in any case, the rest is a linux issue. I suggest askign a mdoerator (via the request attention button) to include this question in at least the linux zone (I don't know if you can do it yourself, have a look among the links/buttons you have)
I installed lazarus on linux but I already had the gtk development packages installed so I cannot tell you if any of those listed depend on others. but when you will try to install them, you will be notified if they do. and keep in mind, you need those packages from your installation CDs, otherwise you might have some versioning issues there ;)
0
 

Author Closing Comment

by:EXF_Pilatus
ID: 31508648
Thanks for your advice. FPC has proven, in the meantime, that it works for my program as well.
0
 
LVL 28

Expert Comment

by:ciuly
ID: 22794339
B grade again, after I suggeste dyou to read the grading tips yesterday. ok. have it your way.
0

Featured Post

Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

Join & Write a Comment

Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
Jaspersoft Studio is a plugin for Eclipse that lets you create reports from a datasource.  In this article, we'll go over creating a report from a default template and setting up a datasource that connects to your database.
The viewer will learn how to use and create keystrokes in Netbeans IDE 8.0 for Windows.
The viewer will learn how to synchronize PHP projects with a remote server in NetBeans IDE 8.0 for Windows.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now