Solved

Problem in booting x86 Solaris 10 into 32-bit Mode

Posted on 2008-10-22
9
2,694 Views
Last Modified: 2013-12-21
Hi,

We currently have the i86 Solaris 10 installed onto a Sun Ultra 24 platform. The following command verifies this:-

[bash-3.00# uname -a
SunOS unknown 5.10 Generic_127112-10 i86pc i386 i86pc]

The default operating mode is 64 bit  based on the following isainfo -v output:-

bash-3.00# isainfo -v
64-bit amd64 applications
        cx16 mon sse3 sse2 sse fxsr mmx cmov amd_sysc cx8 tsc fpu
32-bit i386 applications
        cx16 mon sse3 sse2 sse fxsr mmx cmov sep cx8 tsc fpu

I attempted to use the eeprom boot-file=kernel/unix command to boot into 32-bit mode but on boot up I get the following errors displayed:-

/kernel/drv/nvidia
undefinied symbol '_nv013847rm'
WARNING mod_load : Cannot find module 'nvidia'
WARNING consconfig : No Screen found
Can't Find Driver for Console framebuffer

The system then reboots it self to the GRUB (0.95) loader and then when you attempt to load it up again it fails with the same error. I've had to manually change the /boot/solaris/bootenv.rc file to put it back to 64-bit so that the system willl at least boot up proerly.

Can anyone advise as to what the above errors mean - they seem to relate to the video drivers as far as I can tell but I'm not sure on how to go about resolving this....

Is there something I'm doing anything wrong or if there's another method that I could try. We need to boot the system into 32-bit mode to run 32-bit only code.

Many Thanks

Michael
0
Comment
Question by:mikesung99
  • 5
  • 3
9 Comments
 
LVL 22

Expert Comment

by:blu
Comment Utility
Sounds to me like the 32bit version of the nvidia driver is corrupted. The symbol in question is not dynamic and it is pretty difficult for it not to be found. The first thought I have is that you have the 64 bit driver installed where the 32 bit driver should be, but that is just a wild guess. Beyond that, I would suggest reiinstalling the nvidia driver.
0
 

Author Comment

by:mikesung99
Comment Utility
Thanks for the quick post to this matter. I've had a check on the system, specifically in /kernel/drv and I've found the 32-bit nvidia and 64-bit drivers:-

bash-3.00# cd /kernel/drv
bash-3.00# ls -lrt nvidia
-rw-r--r-x   1 root     sys      8643504 Dec 12  2007 nvidia
bash-3.00# file nvidia
nvidia:         ELF 32-bit LSB relocatable 80386 Version 1

bash-3.00# cd /kernel/drv/amd64
bash-3.00# ls -lrt nvidia
-rw-r--r--   1 root     sys      11220560 Dec 12  2007 nvidia
bash-3.00# file nvidia
nvidia:         ELF 64-bit LSB relocatable AMD64 Version 1

Do the drivers appear to be in the correct place? Besides a re-install of the driver - is there some way to temporarily disable the attempted load up of the nvidia driver at bootup? for this intial phase, I'm not too concerned if it doesn't boot up into the Solaris Java Desktop interface as we'll be remotely accessing the system via telnet for most of the time.

Thanks

Michael
0
 
LVL 22

Expert Comment

by:blu
Comment Utility
You could try booting into the failsafe mode, and then run kdmconfig. If you configure to use Xsun instead of Xorg, you should be able to choose the VGA driver and complete the normal boot up.
0
 
LVL 4

Expert Comment

by:urgoll
Comment Utility
Not to sidestep the question, but you do not need to boot in 32-bit mode to run 32-bit programs. When in 64-bit mode, you can run both 32-bit and 64-bit programs.

I believe you can completely disable the graphical mode login and fall back to the text console by running this commands as root:

svcadm disable cde-login:default

Hope this helps,
Christophe
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 

Author Comment

by:mikesung99
Comment Utility
Hi,

I've booted  into failsafe mode (via GRUB) andit asks if I want to mount solaris 10 8/07 s10x_u4wos_12b X86 (/dev/dsk/c1d0s0) - "y" was selected and this is mounted to /a.

I've not used kdmconfig before - but I've found that it's in /usr/sbin - I've tried to run it from this directory but I think it's just a symbolic link to the /openwin/bin/kdmconfig and as such comes up with "not Afound". Sorry for the newbie question but how would I initiate kdmconfig

Thanks

Michael
0
 

Author Comment

by:mikesung99
Comment Utility
Thanks for the input Christophe,
I was under the impression that you could run both 32-bit and 64-bit apps in 64-bit mode but came across some issues when attempting to install some 3rd party software which claims is only supported on x86 32-bit solaris. It was suggested that we boot into 32-bit mode to see if this makes a difference.

I've used svcadm to disable cde-login but when I reboot (into 32-bit mode) I still get that same problem with the nvidia and it then reboot itself. I just typed in the scvcadm command - do i need to somehow save it befoer I reboot in solaris 10?

Thanks

Michael

0
 
LVL 22

Accepted Solution

by:
blu earned 500 total points
Comment Utility
I just had a couple of people try to boot Solaris 10 on 2 other Ultra 24's and neither were able to boot into 32 bit mode with the nvidia driver. We didn't see the same message you got, but clearly there are issues with that driver in 32 bit mode.

If you run "svcadm disable cde-login" it will disable the start up of the X server. I am not sure that is going to help, though. Your problem is happening earlier in the boot process. From the messages, the system cannot configure the console at all without the nvidia driver.

I think that running kdmconfig while you are up and running in 64 bit mode should still work. Try that.

0
 

Author Comment

by:mikesung99
Comment Utility
Hi,

We've managed to disablethe CDE so that now when we boot up (in 64-bit mode), we just get the command prompt. Whilst in 64-bit mode, I ran kdmconfig and specified that XSun should be used,we then changed the video device to use "XF86-VGA VGA-Compatible video cards". This was then tested (in KDMConfig and the driver seemed to be ok). I then ran eeprom boot-file=kernel/unix to set 32-bit mode and then resrarted the system.

when the system came back up again, it still reported the same issue with the nvidia driver and then rebooted itself. I was just wondering if I need to take any other steps after making the changes in kdmconfig or should I have selectd a different VGA driver? Alternatively, are there any files tat I can edit to explicitly disbale the loading o the nvida driver?

Thanks

Michael
0
 

Author Closing Comment

by:mikesung99
Comment Utility
Thanks for your help on this issue blu - Still not able to boot sucessfully into 32-bit mode but think we've isolated it now as an issue with the nvida driver
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

How can this article save you time AND money?  In just a few minutes you may discover something you didn't know existed that is easy enough for you to fix yourself!
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now