Solved

Stop recipient policy from applying to contacts

Posted on 2008-10-22
9
518 Views
Last Modified: 2011-10-19
I read the article http://support.microsoft.com/kb/319201 posted previously, but it is geared more towards changing or adding an additional address.  It would be nice to know how to do this strictly for Contacts.  Do I need to add an address to create the policy?  This is what I have currently completed, but my e-mail address tab disappeared.

1.  Change RUS service to never run.
2.  Used ADModify to import Contacts.
3.  Used ADModify.Net to uncheck "Automatically Update e-mail addresses based on Recipeint Policy" for all imported Contacts.
4.  Changed RUS service to always run.

Any help with this is greatly appreciated.  Thanks..
0
Comment
Question by:ccrocket08
  • 5
  • 4
9 Comments
 
LVL 3

Expert Comment

by:dsolaris
ID: 22778161
You can create a Policy that filters just on Users, Groups and Public Folders and delete the Default Policy.  However I don't recommend this.
0
 

Author Comment

by:ccrocket08
ID: 22778749
Then what would you suggest?
0
 
LVL 3

Expert Comment

by:dsolaris
ID: 22778813
The manual method that you performed really.  Are there any particular reasons to have it remove the other addresses that Exchange stamps.

I take it you need the contacts to appear in the GAL correct?  If so then the RUS has to touch it at least once in order to stamp ShowInAddressBook.
If the object does not match any Recipient Policy then ShowInAddressBook will never be stamped and the contact will not show up in the GAL.

You could try this.  Create a new Policy that applies only to Contacts, but the issue is that you have to enter some sort of SMTP address domain, so the contacts will always have their external and at least one other SMTP address.
0
 

Author Comment

by:ccrocket08
ID: 22785699
OK, I created a recipient policy to added a bogus e-mail address to all users that do not have the primary SMTP address.  I import my contacts, uncheck "Automatically Update e-mail addresses based on Recipeint Policy", then my new policy runs and overwrites the SMTP addresses I imported to the bogus e-mail address.  Why doesn't the policy append the bogus address?
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 3

Expert Comment

by:dsolaris
ID: 22786045
What is it filtering on?  Is is set to apply to contacts as well or only users and groups?
Can u paste the filter here?
0
 

Author Comment

by:ccrocket08
ID: 22786312
If you need to look at something else, please let me know.  Thanks..
Contactpolicy.doc
0
 
LVL 3

Accepted Solution

by:
dsolaris earned 125 total points
ID: 22788537
You want this to apply to all contacts correct?  If so your filter woudl just look like:
(&(&(& (mailnickname=*) (| (&(objectCategory=person)(objectClass=contact)) ))))

Jsut to make sure of yoru process.  You are using ADMOdify to import the contacts.  Once they are imported you are clearing "Automatically Update e-mail addresses based on Recipeint Policy".  When you do the imported SMTP addresses are removed and the bogus one is being applied?  If so that is strange as when you clear that check box the RUS is told not to touch it.  I wonder if they are getting applied once they are imported.

You can try this:
Set the RUS schedule to Never Run
Perform your import
Clear the Check Box
Wait a bit for AD replication
Set your RUS back to what you want it set to.

Since you are using ADModify to create the objects, that is considered a programatic opeartion and did not go thru the actual APIs to create the obects so the behavior might be erratic.  To test, what behavior do you see when you manually create a contact in AD (not using ADModify)?  Do you get the same results?
0
 

Author Comment

by:ccrocket08
ID: 22788648
I figured this out.

My recipient policy was filtering on "EMail Addresses" instead of "EMail Addresses (External)".  As soon as I changed this, ran my import again, this policy did not change my primary e-mail addresses.  You also do not have to uncheck "Automatically Update e-mail addresses based on Recipeint Policy".

Thanks for all of your help.
0
 
LVL 3

Assisted Solution

by:dsolaris
dsolaris earned 125 total points
ID: 22788679
Good the RUS is gone in 2007 though.
Glad you figured it out.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now