?
Solved

Cisco 2811 Router with Qwest Internet T1

Posted on 2008-10-22
8
Medium Priority
?
1,010 Views
Last Modified: 2012-05-05
I have a Cisco 2811 router with a WIC card. I need a real basic config sample for a Qwest Internet T1 circuit.

Thanks
0
Comment
Question by:HCCI_IT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
8 Comments
 
LVL 6

Expert Comment

by:aschaef217
ID: 22781679
When you do a show run do you already see a Serial interface that looks like Serial 0/0?  If you do then you just need to enter the second part of the configuration, if you don't then you'll need to use both the first and second part of the config.

controller T1 0/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24

interface Serial0/0
 description Qwest T1
 encap ppp
 ip address <your public IP> <subnet>

Not sure if you needed more configuration as far as configuring the FastEthernet ports for the inside LAN, just post back if you need additional help or if that doesn't work.
0
 
LVL 6

Expert Comment

by:aschaef217
ID: 22781681
When you do a show run do you already see a Serial interface that looks like Serial 0/0? If you do then you just need to enter the second part of the configuration, if you don't then you'll need to use both the first and second part of the config.

controller T1 0/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24

interface Serial0/0
description Qwest T1
encap ppp
ip address <your public IP> <subnet>

Not sure if you needed more configuration as far as configuring the FastEthernet ports for the inside LAN, just post back if you need additional help or if that doesn't work.
0
 

Author Comment

by:HCCI_IT
ID: 22781744
Yes, I will need config info for the FE interface as well.

Basically there will be the Serial Interface with the WAN IP info, a route back to the ISP, and the FE interface to serve up the LAN public IP's.

0
ATEN's HDBaseT Presentation at InfoComm 2017

Hear ATEN Product Manager YT Liang review HDBaseT technology, highlighting ATEN’s latest solutions as they relate to real-world applications during her presentation at the HDBaseT booth at InfoComm 2017.

 
LVL 6

Expert Comment

by:aschaef217
ID: 22781757
Can you post the show run with the WIC card you've got installed.  I'll put together the full config just like I did above and you'll have to fill in the public IP, subnet, and default route that Qwest provided you.
0
 

Author Comment

by:HCCI_IT
ID: 22782060
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router123
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address dhcp
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
 no fair-queue
!
interface Serial0/1/0
 no ip address
 shutdown
!
ip classless
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end
0
 
LVL 6

Accepted Solution

by:
aschaef217 earned 500 total points
ID: 22782148
See code below.  In the case where there was a shutdown interface I have just written no shutdown to indicate that you'll need to remove that from the config.  I have indicated all changes with a - preceeding the line.  I included a dhcp scope just in case you are using the router for DHCP and NAT, but you can remove these if you have a firewall or something else taking care of the NAT and DHCP.
Let me know if you have any trouble with that.

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router123
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!
!
!
-ip dhcp pool Computers
-  network 10.10.10.0 255.255.255.0
-  default-router 10.10.10.1
-  dns-server <DNS1 IP Here> <DNS2 IP Here>
!
!
!
!
!
!
!
interface FastEthernet0/0
- ip address 10.10.10.1 255.255.255.0
- no shutdown
- ip nat inside (dont use if you have a firewall doing nat)
- ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
- no ip address
- shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
- ip address <public ip from qwest> <subnet from qwest>
- no shutdown
- description Qwest T1
- encap ppp
- ip nat outside
- ip virtual-reassembly
 
!
interface Serial0/1/0
 no ip address
 shutdown
!
ip classless
!
- ip route 0.0.0.0 0.0.0.0 <Qwest provided Gateway>
 
ip http server
no ip http secure-server
!
!
- ip nat pool pool1 <qwest public IP> <same qwest public IP> netmask <qwest provided subnet>
 
-ip nat inside source list 1 interface Serial0/0/0 overload
-access-list 1 permit 10.10.10.0 0.0.0.255
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end

Open in new window

0
 

Author Comment

by:HCCI_IT
ID: 22786820
Yes, I will have a firewall doing the Nat. Basically, the router will be completely public. FE LAN interface will be service up our public IP ranged that is being routed by our ISP.

Will I need the access-list, ip nate inside, ip virtual-reassembly commands? Also, I do not need DHCP setup so I am assuming those can all be removed as well.
0
 
LVL 6

Expert Comment

by:aschaef217
ID: 22787293
Yeah, in that case go ahead and get rid of the access-list, the ip nat statements on both the serial and FE interface, and DHCP.  You can leave ip virtual-reassembly statements on both interfaces.  
Use the following for your FE configuration
ip address <public IP from your available pool> <subnet mask>
no ip redirects
no ip proxy-arp
no ip unreachables
no ip mroute-cache
speed auto
duplex auto
no cdp enable
no shut
 the serial interface will still have the public ip and subnet which Qwest has assigned for your router.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a guide to configure bridging on Cisco Routers.  This is something I never knew was possible until after making a few phone calls to Cisco.  Using bridging saved our company money by not requiring us to purchase a new switch.  Bridgi…
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question