OpenVPN clients can see each other but not the server

Here is my scenario:
Multiple client machines (XP and linux) IP: 10.50.50.6,10,26,etc.
Single Server (Win2003 server) IP: 10.50.50.1

I setup openvpn on the server, generated the keys, and set the client-to-client flag.
Everything works beautifully between the clients, BUT... the clients can not ping the server either by name or IP.  no software firewalls are installed on the server, and the clients all have their tfirewalls urned off.  Can someone help me configure this beastie to allow the clients to ping the server and vice-versa?
Attached is my server.ovpn file.  Any ideas?
port 1194
proto udp
dev tun
ca ca.crt
cert server.crt
key server.key
dh dh1024.pem
server 10.50.50.0 255.255.255.0
ifconfig-pool-persist ipp.txt
client-to-client
keepalive 10 120
comp-lzo
persist-key
persist-tun
status openvpn-status.log
verb 3

Open in new window

LVL 1
Digital_SkreamAsked:
Who is Participating?
 
m_adamczykConnect With a Mentor Commented:
I believe the problem is that you're using dev tun (for routed tunnel) yet you're specifying the same subnet for the server and the remote clients (a bridged tunnel).

The line "client-to-client" is was allows your clients to reach each other.

Easiest fix will be to change the server config file to specify a different subnet for your clients, so change
server 10.50.50.0 255.255.255.0
to something like
server 10.50.51.0 255.255.255.0

Also include in the server config
push "route 10.50.50.0 255.255.255.0"
so your remote clients know how to access LAN IPs.

Alternatively, you could leave your settings as they are and change your server config to use dev tap but then you have to make more changes to the server config file AND to the client config files. The long term advantages then include DNS info passing over your VPN tunnel (among other benefits).

Hope this helps.
0
 
Digital_SkreamAuthor Commented:
Actually, I solved the problem myself about 3 hours ago, and just hadn't updated this question.
The problem was that the server had RRAS turned on, and the Windows firewall settings were prohibiting the transmission of data.
I disabled the RRAS (wasn't beign used at this point), and turned ON the windows firewall/ICS.  Then, I edited the settings for the windows firewall and excluded the openvpn tun adapter.
Everything works fine.
However, since you were the only person in 3 days to post an answer to my question, right or not, i will give you the points!
Thanks anyways!
0
 
m_adamczykCommented:
Thanks for the points, and especially for the update - it will be helpful for me to know when configuring OpenVPN on other Windows Servers. Glad to see it's working for you. I've been very please with OpenVPN's reliability and stability after getting through the challenging configuration.

Cheers!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.