SQL giving lot of problem

I cannot  neither create a database in SQL nor delete the
existing database and reporting the error.
Error Detail - "Errors in the metadata manager. The dimension with ID of 'Date', Name of 'Date' referenced by the 'Item' cube, does not exist.
Errors in the metadata manager. An error occurred when loading the Item cube, from the file, '\\?\C:\Program Files\Microsoft SQL Server\MSSQL.3\OLAP\Data\iCube_Dev_Partitions.0.db\Item.1.cub.xml'
venkatarathnamAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
ee_autoConnect With a Mentor Commented:
Question PAQ'd, 250 points refunded, and stored in the solution database.
0
 
Sander StadSysteemontwikkelaar, Database AdministratorCommented:
Have you already installed SP2 for MS SQL 2005?
0
 
jmoss111Commented:
If you detach the database then you can delete it.
0
 
venkatarathnamAuthor Commented:
In Business Intelligence Development Studio (BIDS) select your solution in Solution explorer, right mouse click and select Rebuild. You should not get any error during this step.
In BIDS select menu item "Project" and choose "Properties" menu item
Go to "Deployment" tab and change "Deployment Mode" to "Deploy All". Change Processing Option to "Full processing", or to "Do not process" if you are planning to process latter. Close this dialog.
Select your solution in the Solution explorer and choose "Deploy" item.
If reason for above stated error was metadata inconsistencies, you should see no errors during deployment and/or processing.
Change your deployment setting back to what you usually use.
If you are getting similar error during processing, then there is a good chance that data folder that contains MOLAP data is corrupted. To fix this you have to:

Stop Analysis Services service
Make sure you have source deployment files for database that is corrupted
Drop database files from dataDir folder(all the files are deleted)
Start Analysis Services service
Deploy database from source files
Process database
 If you are getting this error when restoring backup, there is a possibility that you are trying to restore backup done from SP2 Analysis Services machine on Analysis Services machine with older service pack.
0
All Courses

From novice to tech pro — start learning today.