Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

how to resolve the access denied error message while opening application with .msc extension?

Posted on 2008-10-23
5
Medium Priority
?
974 Views
Last Modified: 2012-05-05
OS with SBS Server 2003 running Ninja Email Security, Symantec antivirus 10.2
While opening any application with .msc extension (such as dsa.msc, gpedit.msc etc), I get an access denied error message.
I have tried the following with no success.
>cd /d %windir%\system32
>regsvr32 /n /I userenv.dll
>cd wbem
>mofcomp scersop.mof
>gpupdate /force

Any help with be appreciated.
0
Comment
Question by:purruna
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 3

Expert Comment

by:Karl12347
ID: 22784580
Are you running the application with administrator credentials? May be that the probram will not load for standard users? Try using the Runas command


Regards
Karl
0
 

Author Comment

by:purruna
ID: 22792873
Thanks Karl for your prompt answer. I have been loggin in as an Administrator account. But when I use runas Administrator even though i am loggin in as administrator, it works.

Any Advice.
0
 

Author Comment

by:purruna
ID: 22838561
My problem still exist. Any advice.
No policy has been udpate. It just happen after the server restart.

Thanks in advance.
0
 

Expert Comment

by:Mike_Orton
ID: 22886187
Re-associated the file type .msc with the correct mmc.exe application and the management consoles should all open fine. The message access denied is a little misleading, as access is not denied when using other methods such as adding a snapin in a new mmc console.
0
 
LVL 1

Accepted Solution

by:
Iceknight earned 1500 total points
ID: 22982905
It sounds like the extension .msc isn't associated with mmc.exe

Try re-associateing them by doing the following:

Navigate to a .msc file such as dsa.msc which should be located at "c:\windows\system32\dsa.msc"
Right click and select properties of the .msc file and if you notice that its set to open with "Unknown application" change it  to open with Microsoft Management Console, by clicking  "Change..." (next to "Opens with"), then "Browse..." and navigate to "c:\windows\system32\mmc.exe". Click "Open", hit "OK", and then close the Properties dialog. After that, the .msc applications should work properly.


Iceknight.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you ever had a hard drive that you can't boot into, but need to change the registry? Here is the solution! This article guides you through accessing and editing a registry of a non-primary drive. To read registry information on a non-prim…
Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question