Solved

Site-to-site vpn, need help, urgent!!

Posted on 2008-10-23
19
969 Views
Last Modified: 2013-11-16
Need to create site-to-site vpn tunnel between cisco pix 501 (6.3(5)) and Watchguard X550E
I've got the how-to for the watchguard and a pix v7 or higher and the pix at this end is a v6.3(5)
Some commands will not work
I'm going mad googling this and also searching on the cisco and watchguard sites
Is now getting very urgent
I need help, either pointing to a link or transcribing the commands from pix v7 to v6.3
I've followed the instructions changing the commands as needed but im now stuck at the end of phase1 where i have to set the attributes for ipsec, the command reads ... tunnel-group <remote ip address> type ipsec-121
what would be the equivalent for this command?
0
Comment
Question by:txarli33
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 6
  • 4
19 Comments
 
LVL 1

Expert Comment

by:lk-data
ID: 22784780
pre-shared-key *
tunnel-group <remote ip address> type ipsec-l2l
tunnel-group <remote ip address> general-attributes


It's not 121 onehundredetwentyone but L2L :-)
0
 

Author Comment

by:txarli33
ID: 22784817
but the tunnel-group command doesnt work with the 501...
0
 

Author Comment

by:txarli33
ID: 22784856
i've read that tunnel-group, username and group-policy are vpn commands added on v7. do i need to use vpdn command to get the same results?
0
When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot has fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

 
LVL 1

Expert Comment

by:lk-data
ID: 22784922
You type i your question:

tunnel-group <remote ip address> type ipsec-121

And it will not work because you have to type

tunnel-group <remote ip address> type ipsec-l2l    <---   Not 121 but L2L

Try that, I have a 501 where it works on !


0
 
LVL 1

Expert Comment

by:lk-data
ID: 22784923
But yes I have ver. 7.. Can't you upgrade ?
0
 
LVL 20

Expert Comment

by:RPPreacher
ID: 22784937
It not ipsec-121

it's ipsec-L2L (lower case L, number 2, lower case L)
0
 

Author Comment

by:txarli33
ID: 22784940
no, is not upgradable, that's waht the cisco site indicates
6.3(5) is the highest stable version
tunnel-group don't work in this version
0
 
LVL 1

Expert Comment

by:lk-data
ID: 22784978
0
 
LVL 20

Expert Comment

by:RPPreacher
ID: 22785017
what do you have so far?  Do you have the isakmp statements?  Post your current config
0
 

Author Comment

by:txarli33
ID: 22785067
yes, the isakmp went well, i had to do some changes but i belive is fine.

here's what i have so far:


: Saved
: Written by enable_15 at 12:26:35.578 UTC Thu Oct 23 2008
PIX Version 6.3(5)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ToUEK.pUzqr7UqCk encrypted
passwd ToUEK.pUzqr7UqCk encrypted
hostname cvacro1r0001
domain-name cvalive.org.uk
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.50.0 255.255.255.0 10.10.10.0 255.255.255.0
access-list acl_grp permit tcp any any eq domain
access-list acl_grp permit udp any any eq domain
access-list acl_grp permit icmp any any
access-list acl_grp permit gre any any
access-list acl_grp permit udp any any eq isakmp
access-list acl_grp permit esp any any
access-list acl_grp permit tcp any host x.x.x.x eq 16502
access-list acl_grp permit udp any host x.x.x.x eq 16502
access-list acl_grp permit tcp any host x.x.x.x eq citrix-ica
access-list acl_grp permit udp any host x.x.x.x eq 1494
access-list acl_grp permit tcp any host x.x.x.x eq smtp
access-list acl_grp permit udp any host x.x.x.x eq 5631
access-list acl_grp permit tcp any host x.x.x.x eq 5632
access-list acl_grp permit tcp any host x.x.x.x eq 3389
access-list acl_grp permit tcp any host x.x.x.x eq https
access-list acl_grp permit udp any host x.x.x.x eq 443
access-list acl_grp permit tcp any host x.x.x.x eq www
access-list watchguard permit ip 192.168.50.0 255.255.255.0 192.168.100.0 255.255.255.0
pager lines 24
logging on
logging trap warnings
logging history informational
logging facility 16
logging host inside x.x.x.x
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.x 255.255.255.240
ip address inside 192.168.50.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool pptp-pool 10.10.10.1-10.10.10.50
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list watchguard
nat (inside) 1 192.168.50.0 255.255.255.0 0 0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group acl_grp in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
isakmp enable outside
isakmp identity address
isakmp policy 9 authentication rsa-sig
isakmp policy 9 encryption 3des
isakmp policy 9 hash sha
isakmp policy 9 group 1
isakmp policy 9 lifetime 86400
telnet 192.168.50.0 255.255.255.0 inside
telnet timeout 15
ssh timeout 30
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 client configuration address local pptp-pool
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn username qadmin password qadmin
vpdn username cva password activeacv
vpdn username sam password Elite2
vpdn enable outside
terminal width 80
Cryptochecksum:457c6980cb462fdef8812eca8efa650a
: end
0
 
LVL 20

Expert Comment

by:RPPreacher
ID: 22785083
Where are your crypto map statements?
0
 

Author Comment

by:txarli33
ID: 22785130
not done them yet, do they belong to the phase1 configuration?
0
 
LVL 20

Accepted Solution

by:
RPPreacher earned 500 total points
ID: 22785139
You need something like this

crypto ipsec transform-set 3DES esp-3des esp-sha-hmac
crypto map outside_map 1000 ipsec-isakmp
crypto map outside_map 1000 match address ACL_NAME
crypto map outside_map 1000 set peer XXX.XXX.XXX.XXX  <--- THE OUTSIDE IP OF THE PEER (WATCHGUARD)
crypto map outside_map 1000 set transform-set 3DES

Your ISAKMP statement should look something like this

isakmp key YOURSHAREDKEY address XXX.XXX.XXX.XXX netmask 255.255.255.255 no-xauth no-config-mode
0
 

Author Comment

by:txarli33
ID: 22785146
i believe i'll do taht on phase2, now im trying to define the ipsec tunnel type
0
 
LVL 20

Expert Comment

by:RPPreacher
ID: 22785172
The ISAKMP statement I sent replaces the TUNNEL-GROUP statement from v7.
0
 

Author Comment

by:txarli33
ID: 22785237
teh address on that isakmp statement, does it refer to the public address of the remote site (watchguard)?  and if so ... do i need to put he netmask??
0
 

Author Comment

by:txarli33
ID: 22785306
also, will these settigns setup ipsec type to L2L?? (i need to set this type as teh watchguard has already been setup )
0
 
LVL 20

Expert Comment

by:RPPreacher
ID: 22785319
teh address on that isakmp statement, does it refer to the public address of the remote site (watchguard)?
YES

  and if so ... do i need to put he netmask??
NO.  Use 255.255.255.255 unless you are connecting to more than 1 public IP

also, will these settigns setup ipsec type to L2L?? (i need to set this type as teh watchguard has already been setup )
YES

0
 

Author Comment

by:txarli33
ID: 22786715
Thanks all for your help !!

very much appreciated
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Configuring NAT in ASA ver. 9.1 4 50
What is the fastest way to transfer data from one notebook to another 26 131
Network access 24 58
Firewall support--by the month? 10 61
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
For months I had no idea how to 'discover' the IP address of the other end of a link (without asking someone who knows), and it drove me batty. Think about it. You can't use Cisco Discovery Protocol (CDP) because it's not implemented on the ASAs.…
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question