?
Solved

Second web server security issue

Posted on 2008-10-23
6
Medium Priority
?
474 Views
Last Modified: 2012-05-05
I am adding a second web server (Web02) to work with the existing Web01 server.  The website for Web02 points to the path for Web01.  When i try to access Web02 via IP address, I get an authentication dialog box (asking for userid/password).  I can't figure out how to give Web02 permissions to the Web01 path.  When I look at permissions on Web01 - I can only see users (such as IUSR_Web01) for the Web01 server and I can't point it to Web02.  
0
Comment
Question by:mpiaser
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
6 Comments
 
LVL 15

Expert Comment

by:pcsmitpra
ID: 22786411
You may define remote server path as Home path for website properties Home Dir  tab, choose resource located on remote server.
0
 

Author Comment

by:mpiaser
ID: 22786513
I have the home path setup on the Web02 IIS configuration to point to the web01/share.  The problem is when I try to access the web02 server by IP address, it asks me for authentication.  When I access web01 by IP address, it does not ask me for authentication.

In Security tab, web02 is pointing to a userid IUSR_DELLSBSR2.  Web01 points to IUSR_WEB01.  I expect that the issue is the IUSR_DELLSBSR2 isn't known  by Web01 (but I can't figure out how to either point Web02 to IUSR_WEB01 or allow Web01 to accept IUSR_DELLSBSR2 as authorized)
0
 
LVL 10

Accepted Solution

by:
harperse earned 375 total points
ID: 22798427
Put Everyone Read security on both the Windows share and NTFS file system for Web01/share.

Best of luck,
harperse
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:mpiaser
ID: 22805777
I put Everyone access on the WEb01 share, the directory, IIS permissions for both Web01 and Web02...but I still get the authentication box.    
0
 

Author Comment

by:mpiaser
ID: 22859040
Anyone else have any ideas?  WEb01 and Web02 are a member of a group.  i can not access Web01's program set from Web02 as it asks for authentication.  

Perhaps the IUSR_DELLSBSR2 user specified in IIS for Web02 doesn't have the right permissions?  How do I even access the permissions for the user (on a non-Active Directory system)?
0
 

Author Closing Comment

by:mpiaser
ID: 31509188
The key problem was that there were subdirectories in the share which had not inherited the security settings.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here are the symptoms: You start receiving calls from users that one of your legacy web apps isn't coming up, so you log into your IIS 5 server to check it out.  When you pull up the services, you notice that the WWW Publishing service isn't runn…
Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question