Messages received by Blackberry, randomly not being shown in inbox of mailbox.

We have recently starting having an issue where people will get emails on their blackberry, but that email never shows up in their inbox in Outlook, which is connected directly up via Exchange..... no pop3 or anything.

It is random though.  95% of the time it works fine, and it doesn't seem to be happening to all users yet.
But lately it's been happening more and more.  Over the last 3 days we've lost somewhere around 15 emails among all the users combined.  They all received the email on their blackberry, but not in their Outlook.

It's also random as to what type of email it happens to.  Sometimes it will have an attachment, sometimes it could be a few simple lines of text.
And it's not going into a junk mail folder.  I checked and double checked that.


Any idea?
ptuttle1319Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kguy18Commented:
Are the users deleting the message off of the blackberry before looking at it in outlook?
0
ptuttle1319Author Commented:
No.  The emails are still on the blackberry.
They can forward a copy to themselves if they want to.
The biggest problem has came in where they will receive an email with an attachment.  And if they forward the email with an attachment from their blackberry, obviously the attachment won't go with it.
0
kguy18Commented:
Did you try a reconcile on the devices?

http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB10720&sliceId=SAL_Public&dialogID=199912258&stateId=0%200%2095769567

From BTSC:

"Turn off then turn on the wireless email message reconciliation option on the BlackBerry device.

1. Go to Messages > Options > Email Reconciliation.
2. Set the Wireless Reconcile option to No and click Save.
3. Set the Wireless Reconcile option to Yes and click Save."
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.