XP Pro Point-of-Sale server denying connection from front-of-house terminals - Event log shows possible DoS

We have a point-of-sale fileserver in a restaurant with 7 front-of-house terminals, all running XP Pro. Every other day, the terminals fail to connect to the fileserver, even though I can VNC to them from the fileserver and ping back to the server by NetBIOS name (so they are obviously still connected). Upon searching the Windows Event Logs, I found this: Event ID 2027 - "The server has detected a potential Denial-of-Service attack caused by consuming all the work-items.  Some connections were disconnected to protect against this.  If this is not the case, please raise the MaxWorkItems for the server or disable DoS detection.  This event will not be logged again for 24 hours." I need to know how to prevent this and keep the connections open.

The server has 2 separate NICs - one for the internet connection for credit card processing and remote support (they're 250 miles away from me), and another for the internal POS network. Only the POS network seems to be affected, so I am looking for a way to disable the DoS detection for that NIC, if possible, or another reason for the blocked connections with an appropriate solution.
TechGuyMikeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TechGuyMikeAuthor Commented:
Already found those solutions, but it sounds like MaxWorkItems should be a dynamic value and I'm hesitant to change it. The event says "OR" disable DoS detection... how do I do that?
0
sk_raja_rajaCommented:
0
TechGuyMikeAuthor Commented:
The Google Books link doesn't provide any information of value for this situation. The NIC in question is on-board, and besides, the site is 250 miles from me, so I am looking for a software config solution I can do remotely.
0
TechGuyMikeAuthor Commented:
Found the specific solution I am looking for. Here is how to disable DoS detection in Windows:
1. Click Start, click Run, type regedit in the Open box, and then click OK.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManServer\Parameters
3. On the Edit menu, point to New, and then click DWORD Value.
4. Type DisableDos for the name of the DWORD value, and then press ENTER.
5. Right-click DisableDos, and then click Modify.
6. In the Value data box, type 1 to disable denial of service attack detection, and then click OK.

Note To enable denial of service attack detection, type 0 in the Value data box.
7. Quit Registry Editor.

Thanks anyway...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
E-Commerce

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.