Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 293
  • Last Modified:

Using Private IP to distribute limited T1 range over Network

My company has upgraded from a Netopia DSL to a T1 Router (Edgewater Networks) with only 4 Usable, external IP.s.  The company Network has 14 users all which need access to the internet and shared resources.  Management is not willing to assign static ip to each user and thus, wants to use private ip's for everyone to share.  The T1 is managed by the ISP using DHCP.  I was told to upgrade my dataswitch to a "Smart switch".  I have installed a Netgear 10/100, 16 port switch without being able to generate private ip's.  The first 4 computers attaching to the network get allocated ip's from the static ip range designated to our T1-Router.  The rest of the users are getting private ip's in a different range (10.0.0.1 etc) with an invalid gateway.  Thus, they can not connect with the first 4, nor do they have internet access.  What am I doing wrong?
0
CoGenie
Asked:
CoGenie
  • 2
  • 2
1 Solution
 
ryansotoCommented:
You need to have an internal DHCP server or you can manually assign IPs to each workstation with 14 workstations that wouldnt be a big deal.
Your router should handle internal DHCP though look thorugh the settings.  If it doesnt then fine what network segment/LAN IP is it assigned to..192.168.1.X
10.0.0.X...

Once you figure that out you can assign manual IP's to your workstations.
0
 
CoGenieAuthor Commented:
The T1 Router only asigns the via DHCP the first (and only four) Usable IP's allocated.  
67.103.201.121 (Gateway and Usable IP's from 122-126.  I have 14 computers needing to access this gateway and they all need to be in the same ip range for shard resources internally.

 I cannot access the router since it is managed by the ISP.  I have verified that while connecting directly (One pc) to the router, DHCP does work.  My problem is that I need a broader range than management has purchased (static IP's) and I have been told that private IP's should resolve this issue.  I just do not know how.
I thought the Smart Switch would automatically handle allocation of private IP's...
0
 
ryansotoCommented:
No a smart switch wont handle IP's.

Your router has an external and internal interface.  You should be able to configure this or your ISP should.  Tell them to turn off DHCP and why its assigning your static IP's is plain dumb.

So call them and tell them this - assign the internal interface to be 192.168.10.X
This puts the internal interface of the router on the .10 network and this is internal.
Have them give the IP of the internal interface 192.168.10.1

Now you can assign internal private IP's statically to your workstations

Workstations can now be assign as such

IP address 192.168.10.2-192.168.10.254

Subnet mask will be 255.255.255.0
Default gateway will be 192.168.10.1
0
 
z_kweckaCommented:
Hi,

Mostly I agree with ryansoto, the only thing I would change is to say that DHCP can stay switched on.

The solution below (and above) will only work if you do not have any incoming connection from Internet. If you do have some, write about them here and then we will try to help you with a specific solution.

Ask you ISP to provide you with Network Address Translation (specifically with overloaded NAT, i.e. Port Address Translation), and DHCP providing your hosts with private IP addresses.

To find out more about what is NAT read this article http://www.webopedia.com/DidYouKnow/Computer_Science/2006/NAT_and_PAT.asp
Good luck
0
 
CoGenieAuthor Commented:
Thanks!
What I have learned from this (very useful) exchange, is that some ISP's do NOT provide private IP ranges and therefore an additional, (Self Manageable) Router should be added between T1 Router and Data Switch.  This may be (and is, in my limited experience) uncommon, however, it was the case here.  

DHCP SHOULD remain on, and with the additional router, can be managed without purchasing additional external (static) ip's.  Cudos to both respondents for accurate ond good advise.  Problem has been resolved.
Thanks!
CoGenie

0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now