Solved

RDP not connecting to XP machine

Posted on 2008-10-23
13
1,144 Views
Last Modified: 2013-11-21
Hello,

I have an issue RDP connecting to a users PC on the local network.  

Both the local and remote PC's are running WIndows XP, SP3 and on the local machine, I enter the IP, click connect, the connect button and IP field disable themselves, but a split second later, those fields are enabled again and no error message and no RDP connection.

On the remote system, I've enabled remote connections, I can telnet to port 3389 and get a blank screen, I've tried disabling Symantec Endpoint Protection, but still have the same problem.

I've checked to make sure terminal services and RPC services running and still cannot connect.

I don't know where to look next.  Any suggestions?

Thanks in advance,

Ronnie
0
Comment
Question by:rbng256
13 Comments
 

Expert Comment

by:thuff
ID: 22789268
Did you verify the firewall is either turned off or allows port 3389?
0
 
LVL 5

Expert Comment

by:gratex_ssd
ID: 22789353
Verify that  service Windows Firewall/ICS is running... Full SEP instalation stop it.
If not, start it, disable FW on network connection and try again.
0
 
LVL 3

Expert Comment

by:Boze19130
ID: 22789499
Yeah when you install SP3 it turns your FW back on...
0
 

Author Comment

by:rbng256
ID: 22789813
The firewall was disabled, I turned it back on, RDP was listed as an exception, couldn't connect.

Then disabled it for the network adapter, which turned firewall back off and still wouldn't connect.

I seem to be getting to the machine, cause if I disable 'Allow remote users' and try to connect, I get an error message, but re-enable it, no error message at all.
0
 

Author Comment

by:rbng256
ID: 22949624
Does anyone have any thoughts on this?

I now have another Dell Optiplex that's doing the exact same thing.
0
 
LVL 2

Expert Comment

by:Briguy_572
ID: 22949696
Ronnie -
you say that "allow remote connections" is checked?  Can you verify that the account you are using is in the "Remote Desktop Users" local group?  I believe that by default members of the local admins can connect... are you a local admin on the destination machine?

Maybe uninstall the symantec Endpoint firewall piece (add remove programs/modify/make unavailable...)
The machine hardware shouldnt matter as long as the OS is Windows XP Pro, firewall is off,
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Author Comment

by:rbng256
ID: 22956755
I check and the account is a member of "Remote Desktop Users" and is in the administrator group.
Disabling Endpoint protection didn't help.  Didn't even get to a point where I would enter the user name, just entered the IP address.

What's strange is that when I try connecting to the machine, the user sees the mouse change to an hourglass momentarily, but all I see is the controls on the RDP client disable and then re-enabled.

0
 
LVL 2

Expert Comment

by:Briguy_572
ID: 22958279
One other thing to look at might be - on the "advanced" tab of the RDP connection, what do you have under the "Server authentication" option?  Dont have this one selected: Don't connect if authentication fails (most secure):
Also, I am assuming you can RDP to other workstations/servers in your environment.
You say that when you attempt to RDP to the machine that the "user" sees the mouse change - in RDP, if you connect you have to either log on as the person that is logged on to the remote PC, or if you connect with different credentials, you are asked if you want to log that person off,  and then log on as you.  When you RDP onto a machine, it then locks the workstation.  If you are looking to remotely control the PC for helpdesk reasons (like help them solve a problem), you might want to think about another free solution such as VNC or using Citrix's free GotoAssist (https://express.gotoassist.com/register.tmpl?SessionInfo=2738369:8802F7CB3AA6857).  You sign up for a beta account, then email the person you are trying to help an invitation (or have them go to the website and enter a session id), they click on a link, and you have remote control.  it is pretty sweet.  Not RDP, but remote control.
0
 

Author Comment

by:rbng256
ID: 23025860
Hmm, I'm not finding an 'advanced' tab on my RDP client.

Yes, I connect to other workstations just fine.  I'm not needing the remote assistance feature, just testing the RDP connection for the user, and they noticed the cursor change.  
0
 
LVL 2

Expert Comment

by:Briguy_572
ID: 23031177
if you click on "options"
rdp.jpg
0
 

Author Comment

by:rbng256
ID: 23036684
Okay, I found the advanced tab on my XP SP3 laptop, tried with this setting and it still did not make a difference.
0
 

Accepted Solution

by:
rbng256 earned 0 total points
ID: 23161683
Okay, I finally figured this thing out:

I re-installed XP and could RDP, but after I installed the ATI drivers that Dell ships with the machine, I was unable to connect.

Went to ATI's site and download the most recent drivers for the video card and I can now RDP again.

Hope this helps anyone else having the same issue with these Optiplex machines.
0
 
LVL 12

Expert Comment

by:ryan80
ID: 26181602
rbnq256,

Thank you for the answer. I had the same exact problem with a new Dell machine. However I have one that has a NVidia card. There must be something about the way that they install them at Dell. I did notice that the driver version is very old that Dell had preinstalled. Once I put on the new drivers, no problem.

Thank you so much for saving me so much time in aggrivation.
0

Featured Post

Do email signature updates give you a headache?

Do you feel like you are constantly making changes to email signatures? Are the images not formatting how you want them to? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today.

Join & Write a Comment

Suggested Solutions

Remote Desktop Protocol or RDP has become an essential tool in many offices. This article will show you how to set up an external IP to point directly to an RDP session. There are many reasons why this is beneficial but perhaps the top reason is con…
Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip is around source server preparation. No migration is an easy migration, there is a…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now