Changing Resolution of Linux Text Guest OS

Hi Experts -

I'm running a text mode Linux machine in VMware Workstation 6.5.  Unfortunately, the window is tiny and I can't figure out how to change the resolution since X is not installed.  I installed VMware Tools and it went through the paces; however, I have experienced no change in performace since installing it.

Any suggestions?  Thanks in advance.
chezbrgrsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

larsgaCommented:
You did not include which Linux distribution you are running as a vmware guest, so these are just general instructions:

VMware provides a driver for X, but not one for text mode.

In text mode, most Linux distributions use the 'vesafb/vesacon' driver to show text mode. This driver talks to the gfx card using the old vesa 2.0 standard that pretty much all gfx cards support.

To use a different resolution, you would need to add a parameter to the kernel boot line to choose which mode to use. vga=791 should give 1280x1024@16bit on most cards. vga=ask should list available modes for your particular card.

This however all depends on whether the kernel in the particular linux distribution you are using includes vesa support. How to add vga= to the boot parameters depends on which bootloader that is used.

0
chezbrgrsAuthor Commented:
It's CentOS 5.2.  Do you know if your reply applies?  Also, can you be more specific as to how add a parameter to the kernel boot line?  I'm a beginner to Linux.  Thanks
0
larsgaCommented:
As far as I know, CentOS uses grub.

Use a text editor and open /boot/grub/menu.lst
It is a system file, so you will need to do this as root.

In it you should find several sections that look like:

title CentOS ....
        root ...
        kernel /vmlinuz .....
        initrd /initrd....

That is, a section is all the lines from 'title' up until (but not including) the next 'title' line. Copy/paste the first section to the bottom of the file, so that you have an exact copy.

Then edit the title line of the copy, change the name to something like 'CentOS vgatest'

At the end of the kernel line, add vga=791 (or vga=ask). Save and reboot.

At boot, you should get a list of different kernels to select. Select the one with the title you set. (If you don't get a list of choices, you probably need to hit 'Esc' to get grub to show the list). If it works fine, you can then move the 'CentOS vgatest' section to the top of the list in menu.lst to make it the default choice.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pétur Ingi EgilssonSoftware Engineer -- ConsultantCommented:
Attached below is a vga parameter chart in HEX code.
You'll need to convert those hex number to dec in order to use them.


 Colours   640x400 640x480 800x600 1024x768 1152x864 1280x1024 1600x1200
  -------+--------------------------------------------------------------
  4 bits |    ?       ?     0x302      ?        ?        ?         ?
  8 bits |  0x300   0x301   0x303    0x305    0x161    0x307     0x31C
 15 bits |    ?     0x310   0x313    0x316    0x162    0x319     0x31D
 16 bits |    ?     0x311   0x314    0x317    0x163    0x31A     0x31E
 decimal |           d785    d788     d791
 24 bits |    ?     0x312   0x315    0x318      ?      0x31B     0x31F
 decimal |           d786    d789     d792
 32 bits |    ?       ?       ?        ?      0x164      ?

Open in new window

0
chezbrgrsAuthor Commented:
Perfect!!!  Thank you!!!
One more question...is it possible to enable something so the mouse cursor comes out of the vm without having to press Ctrl-Alt?
Thanks again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.