Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4636
  • Last Modified:

IE is blocking a Web site "from displaying content with security certificate errors". I can't seem to lower the security to make it display.

I'm using Internet Explorer 7.0.5730.13 on Windows XP, SP3.  I can't access a Web site that I need to purchase a product.  (It's the www.acronis.com site).
The exact error message I'm getting is:
"To help protect your security, Internet Explorer has blocked this website from displaying content with security certificate errors.  Click here for options."
I click on the yellow bar, then I click "Display blocked content".  Then, 5 seconds later, the error message comes up again.
What have I done?
- Under Tools --> Internet Options --> Security, I have reset the Internet security level to Medium, which is the lowest level allowed.
- Under "Custom Level", I have tried to reset "Don't prompt for client certificate selection when no certificate or only on certificate exists.  The default is "Disable".  But every time I change this to "Enable", then re-open IE, the setting has gone back to "Disable".
Help, please!  Thanks.
0
Dwight Baer
Asked:
Dwight Baer
1 Solution
 
pwrBallCommented:
You could try adding it to your trusted sites:

Tools -> Internet Options -> Security tab, click Trusted, click Sites, add acronis.com


0
 
Dwight BaerAuthor Commented:
Great.  Thanks!
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now