Problem while loading profile in Windows XP while logging on to a samba server

Posted on 2008-10-24
Last Modified: 2013-12-16
Oct 24 15:44:05 mainserver samba(pam_unix)[32338]: session opened for user magesh.prabhu by (uid=0)
Oct 24 15:44:22 mainserver samba(pam_unix)[32346]: session opened for user sujatha.p by (uid=0)
Oct 24 15:44:33 mainserver smbd[32351]: [2008/10/24 15:44:33, 0] lib/util_sock.c:get_peer_addr(1224)
Oct 24 15:44:34 mainserver smbd[32351]:   getpeername failed. Error was Transport endpoint is not connected
Oct 24 15:44:34 mainserver smbd[32351]: [2008/10/24 15:44:34, 0] lib/access.c:check_access(327)
Oct 24 15:44:34 mainserver smbd[32351]: [2008/10/24 15:44:34, 0] lib/util_sock.c:get_peer_addr(1224)
Oct 24 15:44:34 mainserver smbd[32351]:   getpeername failed. Error was Transport endpoint is not connected
Oct 24 15:44:34 mainserver smbd[32351]:   Denied connection from  (
Oct 24 15:44:34 mainserver smbd[32351]: [2008/10/24 15:44:34, 0] lib/util_sock.c:get_peer_addr(1224)
Oct 24 15:44:34 mainserver smbd[32351]:   getpeername failed. Error was Transport endpoint is not connected
Oct 24 15:44:34 mainserver smbd[32351]:   Connection denied from
Oct 24 15:44:34 mainserver smbd[32351]: [2008/10/24 15:44:34, 0] lib/util_sock.c:write_data(562)
Oct 24 15:44:34 mainserver smbd[32351]:   write_data: write failure in writing to client Error Connection reset by peer
Oct 24 15:44:34 mainserver smbd[32351]: [2008/10/24 15:44:34, 0] lib/util_sock.c:send_smb(761)
Oct 24 15:44:34 mainserver smbd[32351]:   Error writing 5 bytes to client. -1. (Connection reset by peer)
Oct 24 15:44:34 mainserver samba(pam_unix)[32352]: session opened for user selva.kumar by (uid=0)
Oct 24 15:44:34 mainserver samba(pam_unix)[24942]: session closed for user selva.kumar
Oct 24 15:44:34 mainserver samba(pam_unix)[25527]: session closed for user magesh.prabhu
Oct 24 15:44:34 mainserver samba(pam_unix)[25205]: session closed for user sujatha.p

Above is a sample of logs from the "messages" log file.  We have a network with Windows XP systems (SP2) and patched for all critical updates.

The distribution of Linux we run is Red Hat Enterprise ES 4.0.  The samba server has been configured as a domain controller (without LDAP).  Of late we have observed that Windows XP client systems are posing problems while logging on to the domain.  After entering the username and password, some client systems get stuck at the stage of "Loading Personal profile" and do not proceed further.  Of course, we have figured a way out by unplugging the network cord and logging on and then connecting the cord so that the server can be accessed.

Can someone provide a hint or a solution to solve this problem?
Question by:hariprasad74
  • 3
  • 3
LVL 20

Expert Comment

ID: 22804525
Please refer to this answer fromone of our experts:

I think your Windows XP clients and RedHat samba server are trying to negotiate protocols using different and mismatching ports  
and that's why you have to unplug and reconnect network cables
in order to skip protocol negotiation ( Error: getpeername failed. Error was Transport endpoint is not connected )

Also , try adding the following to your smb.conf file:
 smb ports = 445
(the default is smbports = 445 139).

 Among the new ports used by Windows 2000, Windows XP and Windows Server 2003, is TCP port 445 which is used for SMB over TCP.

The SMB (Server Message Block) protocol is used among other things for file sharing in Windows NT/2000/XP. In Windows NT it ran on top of NetBT (NetBIOS over TCP/IP), which used the famous ports 137, 138 (UDP) and 139 (TCP).
 In Windows 2000/XP/2003, Microsoft added the possibility to run SMB directly over TCP/IP, without the extra layer of NetBT. For this they use TCP port 445.

Author Comment

ID: 22839240
The error messages got cleared out.  But the original problem of Windows XP hanging while loading the profile continues.  

Below is the smb.conf file for reference:

        workgroup = XXXXXXXXX
        server string = server of xxxxxxx Domain
        interfaces =
        obey pam restrictions = Yes
        password server = None
        passdb backend = tdbsam
        pam password change = Yes
        unix password sync = Yes
        client NTLMv2 auth = Yes
        log level = 1
        log file = /var/log/samba/%m.log
        max log size = 1024
        smb ports = 445
        time server = Yes
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        add user script = /usr/sbin/useradd -d /home/'%u' -M '%u'
        delete user script = /usr/local/sbin/userdel '%u'
        add group script = /usr/local/sbin/groupadd '%g'
        delete group script = /usr/local/sbin/groupdel '%g'
        logon script = logon.bat
        logon path =
        logon drive = Z:
        logon home =
        domain logons = Yes
        os level = 99
        preferred master = Yes
        domain master = Yes
        dns proxy = No
        wins support = Yes
        ldap ssl = no
        idmap uid = 16777216-33554431
        idmap gid = 16777216-33554431
        admin users = root
        hosts allow = 192.168.10., 127.
        cups options = raw

        comment = Home Directories
        read only = No
        browseable = No

        comment = Network Logon Service
        path = /home/netlogon
        guest ok = Yes
        browseable = No
        share modes = No

        path = /home/policy
        guest ok = Yes
        browseable = No
        share modes = No

        comment = All Printers
        path = /var/spool/samba
        printable = Yes
        browseable = No
LVL 20

Expert Comment

ID: 22860107
Sure there's problem.
You have to define user profile location on your samba server, so Windows XP
will try to locate user profile (data stored in NTUSER.DAT ) on the server.
A user profile (userprofile, or simply profile is configurated when used in-context) is a feature of the Microsoft Windows operating system, comprising a given user's collection of personal documents and settings on that computer. At first logon, a folder will typically be created under "Documents and Settings" matching the logon-name of the user.
So you need to add {profile} seciton in your samba configuration file.
In the [profiles] section the path variable tells where the profiles are to be placed and make sure the directories are created with right names and permissions.

create mode = 0600
directory mode = 0700
path = /home/samba/profiles/
profile acls = yes
read only = no
writable = yes

Also you may want to tweak a liitle bit more {homes} section of the config file
In the [homes] section the following entries are important :

comment = Home Directories
browseable = no
writable = yes
valid users = %S
read only = no
create mode = 0600
directory mode = 0700

logon home = \\your_samba_server\%U //  (This tells where is the user home directory )

hide files = /*.pst/

Here's a good article on joining Win XP machines to Samba domain

Free camera licenses with purchase of My Cloud NAS

Milestone Arcus software is compatible with thousands of industry-leading cameras for added flexibility. Upon installation on your My Cloud NAS, you will receive two (2) camera licenses already enabled in the software. And for a limited time, get additional camera licenses FREE.


Author Comment

ID: 22883669
Nope, I tried adding those sections in the smb.conf file.  But this simply did not work.  Any other suggestions?  Do you require any logs or other information to troubleshoot further?

Accepted Solution

hariprasad74 earned 0 total points
ID: 22919962
I was able to figure out the problem.  The NTUSER.DAT file under the netlogon folder had a problem.  I have replaced the file and things are working fine now.
LVL 20

Expert Comment

ID: 22923267
Very good,
now you can close question.
At least we tried our best.
sincerely '

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Error installing extension Linux 4 58
nagios remote hosts 9 42
Python variable _ manually assigned 9 63
su - oracle could not open session 6 47
I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

914 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now