red x when sending messages

Why do I receive an red x while sending messages on blackberry?
brian2uzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

edster9999Commented:
I'm guessing you are doing 'reply' not sending new ones.
The message goes off and then appears a second or two later with an 'x'
if you press the menu button one of the options is 'resend' and this works fine.

This happens when you reply to a message that was in your inbox but it is no longer there.  I have a rule on my work pc to download all mails from the server inbox to my local pst inbox as they arrive.  If this pc is on and running outlook then by the time I hit reply the mail is gone as it has been moved.

Your options are :
1. Turn off the rule so all emails are left up top.
2. Close outlook when you are away so it does not run the rule until you come back
3. just hit resend on each mail.

I do not do lots of emails - just reply to urgent ones so I use number 3.
0
ALogvinCommented:
while edster9999 is correct in that that is one of the reasons... the red X happens for LOTS of reasons.

When you get the red X, open that item and scroll UP. There is a hidden section that will give an error message. Let us know that error message.

Also...

How do you get your e-mail? BIS via your service provider? BES with Exchange or Notes?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
monorail1Commented:
ALogvin is correct - there should be somewhat of a specific error message when you go to open the failed message. It could be a service book issue or send as rights amongst other things. Can you paste the error message and elaborate on your current messaging setup?


~ CFJ
0
Gihan_JayCommented:
Try this fix. This is what happened to me too and after fixing it using this solution.

To resolve this issue, complete the following steps:  
1. Export, delete and re-create the BlackBerry Enterprise
Server Messaging Application Programming Interface (MAPI)
profile.
2. Stop and restart the BlackBerry Router,
BlackBerry Dispatcher and BlackBerry Controller.
Important: Restarting certain BlackBerry Enterprise Server
services will delay email message delivery to BlackBerry
smartphones. For more information, see KB04789
0
brian2uzAuthor Commented:
answer led in right direction
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Smartphones

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.