Solved

Cannot get Cisco 2600 to work with cable modem and static IP addresses from ISP

Posted on 2008-10-24
7
777 Views
Last Modified: 2010-04-21
I cannot get my Cisco router to work with my cable modem. We have COX business services with 4 static IP addresses. I am trying to set up the router to work with just one address right now, but I would like to use all 4 in the near future.

Also will this config also apply to a Cisco 1720 with a WIC-1 ENET card? I have to set up a remote location with a single IP address.

For refrence the IP Addresses assigned to me are
72.214.236.189 190 191 192
Subnet mask: 255.255.255.0
DNS 68.13.16.25 68.13.16.30
Current configuration : 1489 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

enable secret 5 XXXXX

enable password XXXXX

!

ip subnet-zero

no ip routing

!

!

!

ip dhcp pool 192.168.50.0/24

   network 192.168.50.0 255.255.255.0

   dns-server 68.13.16.25 68.13.16.30

   default-router 192.168.50.50

!

ip audit notify log

ip audit po max-events 100

!

!

!

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

!

interface FastEthernet0/0

 ip address 192.168.50.50 255.255.255.0

 ip nat inside

 no ip route-cache

 speed auto

 full-duplex

!

interface Ethernet1/0

 description COX Business Internet

 ip address 72.214.236.190 255.255.255.0

 ip access-group 101 in

 ip nat outside

 no ip route-cache

 half-duplex

!

interface Ethernet1/1

 no ip address

 no ip route-cache

 shutdown

 half-duplex

!

interface Ethernet1/2

 no ip address

 no ip route-cache

 shutdown

 half-duplex

!

interface Ethernet1/3

 no ip address

 no ip route-cache

 shutdown

 half-duplex

!

ip nat inside source list 1 interface Ethernet1/0 overload

ip http server

ip http authentication local

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 72.214.236.1

!

!

access-list 1 permit 192.168.50.0 0.0.0.255

access-list 2 permit 0.0.0.4 255.255.255.0

!

snmp-server community public RO

snmp-server enable traps tty

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

 password XXXXX

 login

!

!

!

end

Open in new window

0
Comment
Question by:lostvoid
  • 4
  • 2
7 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22798064
First off, enable IP routing:

conf t
ip routing

The rest of the config looks okay except you have access-list 101 assigned to the e1/0 interface but access-list 101 doesn't exist.

Remote the list from the interface until you have things working:

conf t
int e1/0
no ip access-group 101 in

If you do a "show int e1/0" is the interface up/up?

Can you ping your default gateway (72.214.236.1)?
0
 

Author Comment

by:lostvoid
ID: 22798116
@JFredrick29
I went ahead and removed the lines you suggested and added the ip routing command.

I also show that the Ethernet1/0 interface is up. I still cannot ping my default gateway.
Ethernet1/0 is up, line protocol is up

  Hardware is AmdP2, address is 0007.85fd.2b90 (bia 0007.85fd.2b90)

  Description: COX Business Internet

  Internet address is 72.214.236.190/24

  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:02, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1000 bits/sec, 3 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     14959 packets input, 902052 bytes, 0 no buffer

     Received 14959 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     559 packets output, 47262 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 1 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

Open in new window

0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 500 total points
ID: 22798206
Your config looks okay so I would call COX and have them verify your static IP's have been pushed to your cable modem.  Also verify the IP addresses, subnet mask and default gateway with them.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:lostvoid
ID: 22798403
@JFredrick29

Thanks! It turns out that due to a misconfiguration on Cox's end the cable modem would not allow more than 1 IP to be pulled at a time. I had the cable modem plugged into a switch and that was connected to the old router and the Cisco so I wouldn't loose connectivity while I configured the router. It appears that everything is functioning fine now.
0
 

Author Closing Comment

by:lostvoid
ID: 31509729
Again thanks. I guess some of my Cisco skills have dwindled since I took my CCNA classes. And great call on checking with Cox. I would of never thought their config would be bad.
0
 
LVL 3

Expert Comment

by:leonjs
ID: 22798459
Just a thought for the outside interface Ethernet 1/0 you have it set for  half-duplex? That wouldn't really cause your problem but you will noticed slowness if only one party can communicate at a time. Might want to see if you can change that to AUTO.

Also have you tried configuring E1/0 to a different Static IP in your block?
I had a situation like this one time and we had to change /24 to a notation appropriate for the block of IP addresses assigned to the company.  In other words try using this as your subnet mask 255.255.255.248

Last but not least have you tried connect the cable modem to a laptop to verify service availability should work the same.

0
 

Author Comment

by:lostvoid
ID: 22798613
@leonjs

As COX does not provide for full duplex in the cable modem I have to use half-duplex. I have had to use half duplex in every Cisco config that I have done in this area. As for setting the speed to auto is invalid for the 4E card as it has 4 10Mbps ports. Also I verified the subnet mask with COX when I called them. It didn't sound right to me either but the subnet mask is 255.255.255.0. Lastly I knew the connection worked because we were using a D-Link consumer grade router previously, however it did not allow for the multiple IPs and it was not able to keep up with the traffic.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now