Solved

Losing bandwidth using Cisco PIX 501c from the cable modem to the PIX

Posted on 2008-10-24
16
1,088 Views
Last Modified: 2013-12-14
We have cable internet service that is supposed to provide us with 10.0 mbps.  When I connect a computer directly to the cable modem the test show a bandwidth of 10.1 mbps.  I then connect the cable modem to the PIX and connect my computer to the PIX and the bandwith tests at 7.6mbps.  Is this normal?  If not is there something in the configuration for the PIX (below)that is affecting the bandwidth? Or is this modek of PIX the cause, and if so what can you recommend?
PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname cisco-pix
domain-name abby.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
name 10.0.0.102 abbatronpdc
name 10.0.0.103 abbatrondc1
access-list 101 permit ip 10.0.0.0 255.255.255.0 10.0.50.0 255.255.255.0
access-list 101 permit ip host 10.0.0.13 10.0.50.0 255.255.255.0
access-list 101 permit ip host 10.0.0.11 10.0.50.0 255.255.255.0
access-list 101 permit ip host 10.0.0.115 10.0.50.0 255.255.255.0
access-list acl-out permit icmp any any
access-list acl-out permit tcp any host nn.nnn.nn.nn3 eq 3389
access-list acl-out permit udp any host nn.nnn.nn.nn3 eq 3389
access-list acl-out permit ip any host nn.nnn.nn.nn6
pager lines 24
logging on
logging buffered errors
logging trap debugging
logging host inside 10.0.0.100
interface ethernet0 10baset
interface ethernet1 10full
mtu outside 1500
mtu inside 1500
ip address outside nn.nnn.nn.nn3 255.255.255.0
ip address inside 10.0.0.199 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.0.50.1-10.0.50.254
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3389 abbatrondc1 3389 netmask 255.255.255.
255 0 0
static (inside,outside) udp interface 3389 abbatrondc1 3389 netmask 255.255.255.
255 0 0
static (inside,outside) nn.nnn.nn.nn6 10.0.0.68 netmask 255.255.255.255 0 0
access-group acl-out in interface outside
route outside 0.0.0.0 0.0.0.0 nn.nnn.nn.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
no sysopt route dnat
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 split-tunnel 101
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet 10.0.0.0 255.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 210.107.171.346 255.255.255.255 outside
ssh timeout 60
terminal width 80
0
Comment
Question by:mikeplastic
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
  • 3
16 Comments
 
LVL 20

Expert Comment

by:RPPreacher
ID: 22799017
Your inside connection is half duplex.

interface ethernet0 10baset
interface ethernet1 10full
0
 

Author Comment

by:mikeplastic
ID: 22799322
It is already confifgured as you indicate??
0
 

Author Comment

by:mikeplastic
ID: 22799334
If this is half duplex are you suggesting to configure it as full duplex and how so?
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 

Author Comment

by:mikeplastic
ID: 22799415
Should these lines read:
interface ethernet0 100full
interface ethernet1 100full
0
 
LVL 20

Expert Comment

by:RPPreacher
ID: 22799425
Your inside is half duplex.  Make it full duplex.

#config term
(config)#interf ethernet0 10full
(config)#exit
#write mem

easy cheesy
0
 

Author Comment

by:mikeplastic
ID: 22799443
Great - should I make it 100 rather than 10?
0
 
LVL 20

Expert Comment

by:RPPreacher
ID: 22799466
Ethernet is not 100.  That is fastethernet.  So 'no'.
0
 

Author Comment

by:mikeplastic
ID: 22799563
I get the error message that
"ethernet0 interface can only be set to 10baset"
0
 
LVL 20

Accepted Solution

by:
RPPreacher earned 125 total points
ID: 22799646
OK... well, that explains it.  The half duplex is why you are losing bandwidth.  There is no fix except getting a better PIX.
0
 

Author Comment

by:mikeplastic
ID: 22799790
Any suggestions as to what will accomplish what we have defined in this PIX only doing that full duplex?
0
 
LVL 20

Expert Comment

by:RPPreacher
ID: 22799808
What?

The PIX is only capable of half duplex.  The half duplex is causing the reduction in bandwidth.  Full duplex support is a hardware issue not a configuration issue.

End of story.
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 125 total points
ID: 22803418
See if you have auto as an option

interface ethernet0 auto
interface ethernet1 100full  <== eth1 is internal and you cannot change it

PIX calls all interfaces "ethernet" whether they are 10M or 10/100

Are you sure this is a little 501 and not a 506? Can you post result of 'show version'
If 506, then you can upgrade from 6.2.2 to 6.3(5) and it may give you 10/100 options on the interfaces
0
 

Author Comment

by:mikeplastic
ID: 22805514
cisco-pix# config t
cisco-pix(config)# interface ethernet0 auto
ethernet0 interface can only be set to 10baseT.
Usage:  interface <hardware_id> [<hw_speed> [<shutdown>]]
cisco-pix(config)# show version

Cisco PIX Firewall Version 6.2(2)
Cisco PIX Device Manager Version 2.0(2)

Compiled on Fri 07-Jun-02 17:49 by morlee

cisco-pix up 8 days 8 hours

Hardware:   PIX-501, 16 MB RAM, CPU Am5x86 133 MHz
Flash E28F640J3 @ 0x3000000, 8MB
BIOS Flash E28F640J3 @ 0xfffd8000, 128KB

0: ethernet0: address is 0009.e8bf.6af0, irq 9
1: ethernet1: address is 0009.e8bf.6af1, irq 10
Licensed Features:
Failover:           Disabled
VPN-DES:            Enabled
VPN-3DES:           Enabled
Maximum Interfaces: 2
Cut-through Proxy:  Enabled
Guards:             Enabled
URL-filtering:      Enabled
Inside Hosts:       50
Throughput:         Limited
IKE peers:          5

0
 

Author Comment

by:mikeplastic
ID: 22805521
If this PIX cannot handle full duplex should I look for another model (used) that can handle full duplex and will use the same configuration code.  If so which models would you suggest?  Or is there a better new/inexpensive way to handle the 2 static ip addresses and all this config/hardware handles?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 22805928
Your best bet would be a new ASA5505. It is far and away the best on the market to replace the PIX501.
Else if you can find a used 506e or 515e that would be a good alternative.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 22807884
Upgrade your PIX from 6.2 to 6.3

With the PIX Firewall Version 6.3, the settings for the following interfaces have been updated as follows:

"PIX 501 outside interface (port 0) - 10/100 Mbps half or full duplex
"PIX 501 inside interface - 10/100 Mbps half or full duplex

http://www.cisco.com/en/US/docs/security/pix/pix63/release/notes/pixrn635.html#wp131908
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On Feb. 28, Amazon’s Simple Storage Service (S3) went down after an employee issued the wrong command during a debugging exercise. Among those affected were big names like Netflix, Spotify and Expedia.
You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question