Solved

Not able to execute Antispam Agent in Exchange 2007 -

Posted on 2008-10-24
3
441 Views
Last Modified: 2012-05-05
I have installed Exchange 2007 SP 1 on Windows 2008 Server.  Everything is going well, except SPAM.  I did NOT install Edge Transport YET (on second server).

I have read articles and learned that Antispam is integrated in Exchange 2007.  Now, installing AntiSpam Agent is been a failure.

When I start EMS the menu comes up, and I am at powershell C:\window\Systems32.  How would I change the directory to C:\program files.  CD does not work.  (sorry, I am not a programmer but a learner)

I need to install AntiSpamAgents.ps1. (located in c:\program files\microsoft\exchange server\scripts)

The answer could be silly but it is better to learn by asking.
0
Comment
Question by:JD
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 

Author Comment

by:JD
ID: 22801321
Running the command from DOS prompt - does not work.  I get the following TXT file
Copyright (c) Microsoft Corporation. All rights reserved.  
#
# THIS CODE IS MADE AVAILABLE AS IS, WITHOUT WARRANTY OF ANY KIND. THE ENTIRE RISK
# OF THE USE OR THE RESULTS FROM THE USE OF THIS CODE REMAINS WITH THE USER.

# Synopsis: Installs and Enable Antispam agents on Bridgehead roles.
#
# The following agents are installed:
#     1) Connection Filtering
#     2) Content Filtering
#     3) Sender ID
#     4) Sender Filter
#     5) Recipient Filter
#     6) Protocol Analysis
#
# This script doesn't take any parameters.
#
# Usage:
#
#    .\install-AntispamAgents

Help is appreciated.
0
 
LVL 5

Accepted Solution

by:
Probity earned 500 total points
ID: 22801851
Well, to change to program files you can do:

cd "C:\Program Files" -- With the quotes

The exchange Anti-Spam is very weak... I would recommend you check out GFI MailEssentials

www.gfi.com
0
 

Author Comment

by:JD
ID: 22804148
the command with quotes worked and able to execute the command with some errors.  It is very length.  I checked the Microsoft Exchange Console and Hub Transport did create a tab with Antispam.

My favorite is GFI Mail Essentials, I did use it on Exchange 2003 on Windows 2003.  I did install and never worked.  Later on, I got in touch with GFI and they have confirmed GFI does not support Exchange 2007 x86 (32 bit) - NOT YET>

Thank you for your help.
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
As cyber crime continues to grow in both numbers and sophistication, a troubling trend of optimization has emerged over the last year.
Familiarize people with the process of utilizing SQL Server stored procedures from within Microsoft Access. Microsoft Access is a very powerful client/server development tool. One of the SQL Server objects that you can interact with from within Micr…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question