Solved

cannot reinstall R2 (during WSUS reinstallation)

Posted on 2008-10-24
10
920 Views
Last Modified: 2011-10-19
I am trying to reinstall R2 technologies (during WSUS 3 reinstallation), but am getting the following error:

Component: Windows Server Update Services

Setup encountered an error while installing Windows Server Update Services. For more information, see the log files at: C:\Program Files\Update Services\LogFiles.

There are three log files there (attached).

Also, in the event viewer there is an error:


Event Type:      Error
Event Source:      MsiInstaller
Event Category:      None
Event ID:      1013
Date:            25/10/2008
Time:            03:52:25
User:            NBS\nbsadmin
Computer:      NBS-LON02-S01
Description:
Product: Microsoft SQL Server Desktop Engine (WSUS) -- The instance name specified is invalid.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 7b 38 33 42 43 31 42 43   {83BC1BC
0008: 32 2d 46 43 43 34 2d 34   2-FCC4-4
0010: 43 45 44 2d 38 41 33 43   CED-8A3C
0018: 2d 45 42 37 43 44 46 42   -EB7CDFB
0020: 33 43 46 36 41 7d         3CF6A}  

I struggle with WSUS for quite a while now and your help is highly appreciated.

Kind regards,

Jay


WSUSMSDESetup-081025-0352.log
WSUSSetup-081025-0351.log
WSUSCa-081025-0351.log
0
Comment
Question by:jbodys
  • 5
  • 5
10 Comments
 
LVL 5

Expert Comment

by:gratex_ssd
ID: 22802267
Hello Jay!

I would say the error you're getting is caused by the fact, that R2 setup tries to install MSDE which is older than Windows Internal Database which the WSUS3 uses, which I guess you have still installed.

It was not necessary to uninstall R2 technologies when reinstalling WSUS3 at all. However, to get you out of the mess now, do the following:

1, completely uninstall WSUS3
2, completely uninstall Windows Internal Database
3, Reinstall R2 Technologies
4, install WSUS


When reinstalling WSUS3 on a SBS2003R2 box, (if you really want reinstallation or have no other choice, the best is always to do a clean reiinstallation, thus deleting DB and all info asscociated with WSUS) you only need to do following:
1, Uninstall WSUS30SP1 from add/remove programs
2, Uninstall Windows Internal Database (don't worry your monitoring or other DB's won't be affected)
3, Manually delete the WSUS Windows Internal DB storage folder (\WSUS\UpdateServiceDBFiles)
3, Reinstall R2 Technologies if you have uninstalled it already (if not skip this)
3, Reinstall WSUS30SP1, create a new DB
4, DO NOT run WSUS30 configuration wizard found at the end of the setup because you will break R2 Update Services Capabilities (if you don't want to use built in R2 Update Services capabilites, you can use the wizard as you see fit and setup the WSUS any way you want, and skip the rest of this walkthrough)
- from the options in WSUS console:
5, Set product classifications to ALL products
6. Set update languages to only those you wish to have
7. Set synchronization to automatic and the time you wish
8. To restore Update Services functionality in Server management console (you get error in /UpdateServices Application error) you may need to add default auto approval rules by running SQL script from the command line. Follow the guide on this page:
http://technet.microsoft.com/en-us/library/cc708091.aspx (scroll down to I get a "Server Error in '/UpdateServices' Application" error headline)

0
 

Author Comment

by:jbodys
ID: 22803840
Many thanks for your reply.

In regards to the first 4 points:

1) I believe that I have uninstalled WSUS3 (through add/remove programs and also using MSIZAP T {2C0D7E35-EE6E-4DC7-BA13-2C68AEDEB59D} and iisreset, etc)

2) I have uninstalled Windows Internal Database (using msiexec /x {CEB5780F-1A70-44A9-850F-DE6C4F6AA8FB} callerid=ocsetup.exe)

3) I cannot reinstall R2 Technologies... (see error above)

4) I can install WSUS 3.0 SP1 but without R2 technologies (but I don't want that)
0
 
LVL 5

Expert Comment

by:gratex_ssd
ID: 22804217
Thanks for additional info.

My guess is that some "forgotten" registry entry from a newer version is preventing the installation from continuing.

You can try to manually remove all remnants of MSDE installation (also using msizap utility) by using the following the guide at http://support.microsoft.com/?id=320873

Also uninstall WSUS3, WID, if you reinstalled it.

Then check the registry for the key HKLM\Software\Microsoft\Update Services\Server\Setup, change the value of "wYukonInstalled" to 0x0 and ensure that "SqlInstanceIsRemote" = 0x0.

Then go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MicrosoftSQLServer\InstanceNames\
and search through there for all WSUS instances (both new and old instance names) - MICROSOFT##SSEE key, MSSQL$WSUS key (if you find one), and remove them. Be careful and do not remove any other instance names or whole hive.

MICROSOFT##SSEE is wsus 3 (WinInternalDb) instance name.
MSSQL$WSUS is a wsus 2 MSDE instance name.

Try to restart R2 Setup.

Also, I have found other guy who had the same problem, you can read it and maybe find something that applies to you:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_23137503.html



Let me know, we can surely make this work.





0
 

Author Comment

by:jbodys
ID: 22818817
I believe I've done everything you asked me to do. This time the log file was 6 times bigger (about 3mb rather than usual 500kb), but setup failed with exactly the same errors as at the beginning (see log files attached to my first post).

I also read the thread you quoted but unfortunately this guy didn't post the registry entry he was told to remove.
0
 
LVL 5

Expert Comment

by:gratex_ssd
ID: 22820186
Maybe off-track, but after removing WSUS 3 components altogether, did you try to correctly uninstall R2 Technologies itself from add/remove programs before reinstallation?
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:jbodys
ID: 22824869
Hi there,

Initially I had problems with WSUS 3.0 SP1 and was trying to troubleshoot it through uninstalling and reinstalling it as described in the document http://sbsurl.com/wsus in the section "Uninstalling and reinstalling Windows Small Business Server 2003 R2 components on a server that is running WSUS 3.0" and it worked 3 times and then when I was trying to do for the 4th time I started to have problems with reinstalling R2 (as described above).

In other words as far as I remember I was always uninstalling R2 before reinstallating WSUS 3.0 SP1, but it might be that I made a mistake, although I doubt it (what would be worth trying if it was the case?).
0
 
LVL 5

Accepted Solution

by:
gratex_ssd earned 500 total points
ID: 22826993
Well Jay, I have never uninstalled R2 when I was in need of reinstalling WSUS3. I don't think you made a mistake, I just think it was not necessary. I know that document and it is pretty clear.

I have found this interesting article which might be worth a try:

http://msmvps.com/blogs/thenakedmvp/archive/2005/06/09/51416.aspx

I am citing one post from there. In your case, and as I can see from the logs, the file you need is sqlrun03.msi. When you run R2 setup, it creates temp directory and there you can find the file in the directory named WMSDE. run the setup, do not continue, and search for the file. In your log there is location of d:\09edd0acd005d449840d\WMSDE\SqlRun03.msi maybe the string will be different but it should be there. make copy of it somewhere else and try this

this works (replace X with installation directory of WSUS, in your case D:)
start install and make a copy of the extracted package; specifically the wmsde folder.
after rolling back and leaving you with the logfiles go to the copied files and run the sqlserv installer:

D:\Copy of 53fdca17868c30092b78016c\WMSDE>SqlRun03.msi INSTANCENAME="WSUS" BLANKSAPWD=1 TARGETDIR=D:\WSUS\ DATADIR=D:\WSUS\

then retry the R2 install and implicitly choose to install wmsde again..
I ended up with (what appears to be) a working system.
0
 

Author Comment

by:jbodys
ID: 22956251
This is what worked for me:

1. regsvr32 /u psfsip.dll
2. rename psfsip.dll in %windir%\system32 to OLD-psfsip.dll
3. try install again

I have also found this discussion where more options are described:

http://www.archivum.info/microsoft.public.windows.server.update_services/2008-03/msg00216.html

Many thanks for your help!

I'm awarding you all the points as you directed me in the right place.
0
 

Author Comment

by:jbodys
ID: 22956880
Unfortunately this is not the end of the story...

After I've done:

1. regsvr32 /u psfsip.dll
2. rename psfsip.dll in %windir%\system32 to OLD-psfsip.dll
3. try install again

reinstallation was successful. I checked the Server Management and Update Services were there. I checked Monitoring and Reporting and it worked as well. I clicked on Update Services link and I saw typical screen informing me that updates were not synchronized with Microsoft website. I clicked Synchronize Now and walked off the office.

About 2 hours later I tried to log on remotely to the server. There was an error message on the Update Services screen (one of those generated by IIS with lots of errors). I decided to close the Server Management window and check error logs, etc. When I tried to click on the Server Management icon I got the error that Server Management is not a valid Windows application (something along these lines) and the server stopped responding.

I know that I have the Internet connection in the office as I can log on to the gateway. Also, I was able to use the 3rd party remote access tool to briefly connect to one of the PCs on the domain as I was hoping to get the server restarted from within the PC using shutdown command. I got disconnected fairly quickly, though, and the PC is now shown as being offline.

The server eventually responded (after about 20 minutes) to clicking on the Start button, but straight away stopped responding again. I was able to highlight icons on the Desktop for a few seconds and was trying to create a shortcut to Task Manager using right-click, but the server stopped responding and I can only move the mouse cursor around (the arrow has a little hourglass next to it, but the system is not responding nor on the Desktop neither on the taskbar).

Eventually I used ctrl-alt-end that got Windows Security window in front of me, but after clicking Task Manager I ended up with nothing but the cursor on the screen.

Nice.


0
 
LVL 5

Expert Comment

by:gratex_ssd
ID: 22957951
Hi there Jay!

I am glad that you were able to move forward on this, but sorry to hear that things do not work as expected...

I'd appreciate if you'd try to reboot the server normally and if you get the same scenario, try to reboot in safe mode - the point is to get to event logs somehow - application and system logs would be most useful, use filter to show only errors and warnings. Try to find something related and post back here - I cannot exactly guess what went wrong from your (although exhausting) explanation.

Thanks!
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

I’m often asked about newer and larger USB drives connected to SBS2008 and 2011 failing Windows Server Backup vs the older USB drives not failing. As disk space continues to grow and drive technology change SBS2008 and some SBS2011 end up with the f…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now