Solved

External HD suddenly "not formatted" and no longer fully "there"

Posted on 2008-10-25
5
552 Views
Last Modified: 2013-11-14
Hello all,  

I've been searching through some of the other problems that people had with external hard drives suddenly "not being formatted", and think I'm running into the same problem, however, I think I've got a secondary problem which is preventing me from using the same solution that other people have used to fix their problem. On the 2 TB Cavalry hard drive I've got (had it about 2 weeks), it would appear that all the data MAY still be on one of the TB drives, but now the unit is now only showing me the other drive, and it's telling me THAT drive isn't formatted.

I tried looking at the drive with the PC Inspector file Recovery program others have mentioned in the solutions here (eg, http://www.experts-exchange.com/Storage/Hard_Drives/Q_23430839.html), and it does show the drive (I: in my case), but is now showing the HD as only 931.51GB.  

It was working yesterday and I was able to see all the folders/files (now I think about it, it may have only been looking at HD2 which is where I'd copied my files to) - I'm now not 100% sure if I ever saw the unit switching between the drives, but the HD indicator light (which shows which of the two TB drives it's currently "looking at") is set on HD1, and I've a feeling that all my information may be on HD2. I just can't seem to get the device to look at the other Hard Drive to verify that since it's now showing that it's only 1TB vice the 2TB it's supposed to be.

I'd like to make sure I can recover my data from the other HD, but I'm not sure which problem I need to fix first (ie, the fact that a 2TB drive has suddenly become a 1TB, or that the drive suddenly thinks it's not formatted).  I assume that if I try to format this drive, it'll wipe BOTH drives, so don't want to risk that if at all possible.

Does anyone have any ideas of what I need to do, and if so, which problem I should tackle first?

I'm running XP, SP2...     and the box the drive came in said it was preformatted to NTFS.

As additional information, I managed to find the Disk Manager tool, and it's showing the FULL drive size (1863.02GB) and says the drive is Healthy.  However it's NOT showing anything in the File System column (either FAT32 or NTFS - it's just blank).   I tried to "explore" the drive from the Disk Manager by right clicking and "exploring", but then get the pop up message saying the disk isn't formatted again.   When I look at the properties of the drive, it's showing as RAW and has 0 bytes available and 0 bytes used.  I'm not sure if that helps anyone to help me or not!  :(  

Hopefully I've given enough information for someone to help -  I'm a total noob at all this and am just wanting to get access to my files again, and hopefully make the drive realize it's supposed to have 2TBs! (I'll also be attempting to call Cavalry Customer Support on Monday when they re-open. True Murphy's Law here - the drive stopped working about 5 minutes before their customer service center closed for the weekend....)

Thanks in advance!
0
Comment
Question by:Kisaki_kun
  • 3
  • 2
5 Comments
 
LVL 42

Expert Comment

by:Davis McCarn
ID: 22804899
I just had a client with a similar problem on a Lacie 1TB unit.  One of the drives had failed and, since it is a striped raid array, both have to be working.  Luckilly, the drives were identical and I found it was the logic board on one which had failed.  I got another 500GB drive (1TB for you), cloned the failing one to it using the good logic PCA, put the Lacie back together with the original good drive and the coied bad one, and poof, it all reappeared.
0
 

Author Comment

by:Kisaki_kun
ID: 22805573
Thanks Davis - I may have to try that as an end result - I'm sure this is going to sound like a really silly question, but how did you manage to clone the information on the one drive if the computer can't see any files/folders/data on it?  

I'm also debating just returning this Cavalry drive if I can, and then buying two 1 TB drives for back up vice the 2TB.  Here was me thinking I'd be able to save $ and it just seems like it's causing more problems.
0
 

Author Comment

by:Kisaki_kun
ID: 22805785
Alright....  I'm REALLY confused now...     Surprisingly enough, Cavalry customer support was open, and they'd sent me an email suggesting I changed USB cords to the external hard drive. I tried this without succes initally, but then when I rebooted the computer, BOTH problems are gone... as in I now have a drive that's 2TB, is NTFS , AND all the files are back...    

I'm not sure if a USB cord would cause the drive to have a disappearing section, or suddenly decide that it's not formatted....  is that likely, or is it more likely that there's some other problem with my drive? I'd hate to move more data, and have this as a recurring problem...   So maybe I'm looking at a bigger issue than just a USB cord failure?

0
 
LVL 42

Accepted Solution

by:
Davis McCarn earned 500 total points
ID: 22806882
An external unit with two drives being handled by a proprietary controller in a raid configuration is a very bad idea in my opinion.  Lose a drive and your dead, lose the controller and your also dead.  Find documentation, diagnostics, or any real technical help...... I don't think so.

I suspect your second drive decided to spin up.

I use WinHex for cloning because it is a sector copy (so I don't care what O/S it is) and it gives me a report of which sectors failed to be readable.  Almost all of the cloning programs have an option to do a sector copy.
0
 

Author Closing Comment

by:Kisaki_kun
ID: 31510000
Many thanks for your help!  I think I'm going to see if I can exchange this drive for 2 each 1TBs and stay away from the lovely "dual drive" that I thought would be such a good deal!  Cheers!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Bellevue, WA, USA; Late December, 1980 "OK, folks, we nailed the IBM contract. We're going to have many meetings like this to discuss features and functions...and how to move from 86-DOS, the CP/M clone we just purchased, to our baby, MS-DOS. Thi…
In this article we have discussed the manual scenarios to recover data from Windows 10 through some backup and recovery tools which are offered by it.
This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now