How to Access Windows 2008 Terminal Server from outside the office?

Here is the scenario:

I have a Windows 2003 running as the DC on my small network. The server has two NIC cards in which one is connect to my ZOOM DSL modem/router and the other NIC is configured as the Local IP. The ZOOM DSL modem/router is NOT in bridge mode.  The Windows 2003DC handles DHCP IP request for the Local Network in which I have about eight Windows XP workstations.  Everything is working fine all computers can connect to the internet, access server resources, etc.

Now I purchased a second server running Windows 2008 Server. My plan is to make this server a Terminal Server. I have already setup the server to the local network and purchased the Terminal Server License Cal's. I can connect to the Windows 2008 Terminal Server from within the local network without any problem using RDC.  

MY QUESTION IS HOW DO I ACCESS THE WINDOWS 2008 TERMINAL SERVER FROM OUTSIDE THE OFFICE?

Do I need to set the ZOOM DSL modem/Router in bridge mode and run the Internet Connection Sharing Wizard? What port forwarding do I need to do?

Thanks so much for you help.


stew561Asked:
Who is Participating?
 
Raymond JansenConnect With a Mentor Commented:
The port for Remote Desktop (Terminal Server) is 3389. If you have your router in router mode, just forward port 3389 to your terminal server. You should be able to connect.

However, it is saver to make a vpn connection to a vpn enabled router / ssl vpn box first and THEN connect to the terminal server, imho.

Ray
0
 
leegclystvaleCommented:
Yup, 3389 will need to point to your TS server. You will also need an external IP address to connect to RDP of course as well and a DNS server will need to know where it is. Whilst VPN is a more secure way of connecting, coupled with good password enforcement, but it will be a tradeoff on performance as there is a larger overhead due to the encryption used. Depends what you need it for but you should at least try VPN first and if it's too slow, you can use RDP straight through but think of how critical your data is.
 
0
 
stew561Author Commented:
I'm not sure if I have my Modem/Router properly configured. I never congfigured it with a static IP address. I'm just using it right out of the box. That being said the Routers DHCP is turn on and is using the local 10.0.0.X range.

My Current Configuration

NIC #1   ( Which is Connected to the Zoom DSL Modem/Router)

IP Address: 10.0.0.1
Subnet Mask: 255.255.255.0
Gateway: 10.0.0.2
DNS Server: 127.0.0.1


NIC #2    (This is the Local IP)
IP: 192.168.0.1
Subnet Mask: 255.255.255.0
DNS Server 192.168.0.1

I went into the router and configured the port hower I can't connect and can't even ping my Public IP. I am assuming that I first need to configure the Modem/Router to use a Public Static IP.  After that I'm nost sure what to do.
0
 
leegclystvaleConnect With a Mentor Commented:
You need to give your router a public IP address on the WAN interface and it should have a static IP on the LAN interface. If your servers are giving DHCP address then turn off the router DHCP addressing at it will be seen as a rogue DHCP server and create problems.
You should have your default gateway as the LAN router IP address and also your DNS settings should come from your internal DNS server and any other requests should be forwarded to your ISP's DNS servers.
Your public IP address requests should be forwarded to 10.0.0.1 server using port 3389.
Hope that helps
It would be useful if you could diagram your setup and post it with IP addresses.
0
 
leegclystvaleCommented:
Are you still having issues or is it sorted out now?
0
All Courses

From novice to tech pro — start learning today.