IBM x3550 Broadcom BMC5708C will not install drviers

I have an IBM x3550 7978 server with Broadcom BMC 5708C network cards on board.

I can not get the drivers to load - I had the cards working for a while, but every time I reboot they want to re-install.

I've updated the card's firmware, I've re-set BIOS to defaults.

I've tried the latest IBM drivers and drivers direct from Broadcom - the installers finish, but on reboot the cards want to re-install again.

When I point the re-install to the IBM drivers by hand - I get 'Fatal error during install'

Any Idea what this could be?
Who is Participating?
lnkevinConnect With a Mentor Commented:
Go to control panel or computer management and uninstall the driver completely. Get in network place property and delete all current connection. Get in windows registry and remove any broadcom keys

Download and install this broadcom package then reboot and test

erikwhitewayAuthor Commented:
I added a standard USB ethernet interface and that took right away.  I'm realy at a loss as to why this won't load.

More backgound:
The OS is Windows 2000 SP4
It used to be on different hardware with Intel cards (cloned to the new hardware).

Is there a way to clean up all the old network info and just start fresh?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.