Solved

Unable to connect to the Internet through Cisco 851 router

Posted on 2008-10-25
6
1,714 Views
Last Modified: 2012-05-05
I am trying to configure a Cisco 851 router for home use. I used the Cisco SDM CD to create the initial configuration. The WAN port (FastEthernet4) is connected to my cable modem. My PC is connected to FastEthernet0. I have connectivity between my PC and the router, but not beyond the router. Here is my config. What am I missing?
Cisco851#sh run
Building configuration...
 
Current configuration : 3544 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname Cisco851
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
logging console critical
enable secret 5 $1$mauP$dIxW9VJsxNKNW26hI4FRb1
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-2282733268
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2282733268
 revocation-check none
 rsakeypair TP-self-signed-2282733268
!
!
crypto pki certificate chain TP-self-signed-2282733268
 certificate self-signed 01
  3082023E 308201A7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32323832 37333332 3638301E 170D3032 30333031 30303237
  32365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 32383237
  33333236 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100E27C 42E4CCF0 3558E4BA D7A85F51 CD7A7894 97CE8888 2DCB98E7 62DAA37A
  B07C75BA D4B78397 95F1B0A4 4EF24024 0850EC3E E957A876 F22D304D 24020B72
  92CB79FC 8856311A BA88E1FA 0A860087 22441733 DB37DD8D 2193FDCC 58FA9C95
  7C7C04F4 D001EBA4 8FBF7A44 61924D5A E14D547C 1ED34D3B 18C44632 8A6B13D1
  480F0203 010001A3 66306430 0F060355 1D130101 FF040530 030101FF 30110603
  551D1104 0A300882 06526F75 74657230 1F060355 1D230418 30168014 12A0EAA8
  A22CCB4D 0820EA6C C6DC6CD5 AFEEF171 301D0603 551D0E04 16041412 A0EAA8A2
  2CCB4D08 20EA6CC6 DC6CD5AF EEF17130 0D06092A 864886F7 0D010104 05000381
  8100BF52 C294CCD5 A58AC064 E9577C35 1B767FB7 ED151D29 5FD46A8A 2CAB7D95
  ABF3CA35 E4439839 689511DC AE0F6E31 A71DC4CC 3DAAB521 39CBD046 0A7BB96D
  EDC76F4F 04F51316 5D480B3A B4FEE688 E63B268B 1C0FD507 11C07D02 A236F2F3
  435351F3 0790066B 8F3FEFF2 88CE6286 760441A9 B805313C 5FE637F9 A30D79A5 016E
        quit
dot11 syslog
no ip source-route
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.50
!
ip dhcp pool sdm-pool1
   network 192.168.1.0 255.255.255.0
   dns-server 68.105.28.12 68.105.29.12
   default-router 192.168.1.1
!
!
ip cef
no ip bootp server
ip domain name domain.com
ip name-server 192.168.1.1
!
!
!
username admin privilege 15 password 7 071C351C400C0E041B1E
!
!
archive
 log config
  hidekeys
!
!
ip tcp synwait-time 10
!
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 description Public Network Connection
 ip address dhcp
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 ip route-cache flow
 speed auto
 half-duplex
!
interface Vlan1
 description Local Area Connection
 ip address 192.168.1.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
!
ip forward-protocol nd
!
ip http server
ip http secure-server
ip nat inside source list 100 interface FastEthernet4 overload
!
logging trap debugging
access-list 100 remark SDM_ACL Category=2
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
no cdp run
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

Open in new window

0
Comment
Question by:ChessKnight
  • 3
  • 2
6 Comments
 
LVL 10

Expert Comment

by:kyleb84
ID: 22806115
Couple of things i've noticed in the config:

- Make sure the address your cable modem is giving the router isn't in the 192.168.1.0 network!
- Change your
 interface FastEthernet4
 description Public Network Connection
 ip address dhcp
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 ip route-cache flow
 speed auto  <---
 half-duplex  <---

Needs to be:

speed 100
full-dublex

0
 

Author Comment

by:ChessKnight
ID: 22806195
Kyleb84,

I made those two changes, saved and restarted the router but no luck. I don't know if it is related to my problem but I noticed when the router boots back up, I get the following error:
===
no ip dhcp use vrf connected
               ^
% Invalid input detected at '^' marker.


Configuration failed!
SETUP: new interface NVI0 placed in "shutdown" state
===
Any additional help would be greatly appreciated. Thanks.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22806880
Change the FastEthernet4 interface to "speed auto" and "duplex auto".

Can you post a "show int fastethernet4" and a "show ip route".  From the router itself, can you ping 68.105.28.12 (ISP's DNS server)?  Can you ping that from a client?
0
Create the perfect environment for any meeting

You might have a modern environment with all sorts of high-tech equipment, but what makes it worthwhile is how you seamlessly bring together the presentation with audio, video and lighting. The ATEN Control System provides integrated control and system automation.

 

Author Comment

by:ChessKnight
ID: 22807598
I changed FastEthernet4 speed and duplex to auto. I cannot ping the DNS IP from either the router or the client (but maybe the ISP is blocking ICMP?) I've attached show int fastethernet4 and show ip route. Thanks so much for looking at this for me.
Cisco851#sh int fastethernet4
 
FastEthernet4 is up, line protocol is up
 
  Hardware is PQUICC_FEC, address is 0023.3371.13a1 (bia 0023.3371.13a1)
 
  Description: Public Network Connection
 
  Internet address will be negotiated using DHCP
 
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
 
     reliability 255/255, txload 1/255, rxload 1/255
 
  Encapsulation ARPA, loopback not set
 
  Keepalive set (10 sec)
 
  Full-duplex, 100Mb/s, 100BaseTX/FX
 
  ARP type: ARPA, ARP Timeout 04:00:00
 
  Last input 00:00:00, output 00:00:02, output hang never
 
  Last clearing of "show interface" counters never
 
  Input queue: 1/75/1/0 (size/max/drops/flushes); Total output drops: 0
 
  Queueing strategy: fifo
 
  Output queue: 0/40 (size/max)
 
  5 minute input rate 1000 bits/sec, 4 packets/sec
 
  5 minute output rate 0 bits/sec, 0 packets/sec
 
     1672 packets input, 101448 bytes
 
     Received 1672 broadcasts, 0 runts, 0 giants, 1 throttles
 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
 
     0 watchdog
 
     0 input packets with dribble condition detected
 
     902 packets output, 557436 bytes, 0 underruns
 
     0 output errors, 0 collisions, 6 interface resets
 
     0 babbles, 0 late collision, 0 deferred
 
     0 lost carrier, 0 no carrier
 
     0 output buffer failures, 0 output buffers swapped out
 
Cisco851#sh ip route
 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 
       E1 - OSPF external type 1, E2 - OSPF external type 2
 
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 
       ia - IS-IS inter area, * - candidate default, U - per-user static route
 
       o - ODR, P - periodic downloaded static route
 
 
 
Gateway of last resort is not set
 
 
 
C    192.168.1.0/24 is directly connected, Vlan1

Open in new window

0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 500 total points
ID: 22808134
Hmm, you aren't getting an IP address via DHCP.  Try this on the router.

conf t
int fastethernet4
ip address dhcp client-id FastEthernet4
shut
no shut

After, power cycle the cable modem.  If you do a "show ip int brief" and still don't have an IP address on the FastEthernet4 interface, plug a computer directly into the cable modem and see if you get an IP address.
0
 

Author Closing Comment

by:ChessKnight
ID: 31510041
JFrederick29,

Thanks so much!!! That fixed it. Not sure which thing fixed it but after following your instructions, the router got an IP and I could connect to the Internet.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
VIRL IP adress 3 79
WAN Site Edge Routers 15 62
Upgrade firmware on Engenius BH-ENS202Wi-Fi router 5 53
Viber-Only Restriction 6 58
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question