Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 604
  • Last Modified:

Companyweb defaulting to SBS Welcome page

I have a cleint that used their companyweb extensively.  All of a sudden in
August after their line of business vendor installed .net 2.0 we started
experiencing issues.  Thinking it was a conflict between .net 1.1 and 2.0 I
followed all of the KB's I could find.  I just reinstalled Sharepoint
services, restored their companyweb from a back-up and followed the procedure
to move the companyweb into a separate application pool so it was not running
in the same application pool with the line of business application.  
Companyweb was now working on the server, but I had to renew IP's and flush
the DNS cache on the desktops for them to be able to view it.  Within 24
hours everyone was back on the welcome page as opposed to the cpmanyweb when
browsing http://companyweb/default.aspx.

So it must be a DNS issue, however I compared this installation to all of my
other ones and the DNS settings for Companyweb appear to be identical.  I am at a loss.
0
jetconsulting
Asked:
jetconsulting
1 Solution
 
amiteshanandCommented:
To understand your situation, your client was using SBS 2003 as their enterprise server and SBS comes packaged with Exchange and SQL. When you mention Company Web, I am assuming that you are trying to refer it to Windows SharePoint Installation and based on the URL that you have mentioned I feel that its running on Default Port#80. WSS 3.0 needs .Net 3.0 and i feel that your other business application hosted on IIS required .Net 2.0. For this very reason, you re-installed and probably re-configured Application Pools. I think you need to have a seperate websites within your IIS and configure Line of Business Apllication to run on ASP .Net 2.0 mode by managing properties in IIS. However, i need to understand more for the DNS configuration that you have done.
0
 
Dave_ANDCommented:
Open the companyweb website in IIS, go to the IP settings advanced, and in there you will find its listening on port 80. Edit that, and in the "host header value" box type companyweb. This will now set it listening to anything with the header of companyweb to go to this IIS site. for example:

Multipul Identities for this website:

192.168.1.1 companyweb.domain.local
192.168.1.1 companyweb

0
 
jetconsultingAuthor Commented:
In response to Dave AND: The settings listed are what is currently in place.


In response to Amiteshanand: Yes Companyweb is the builtin default site with Sharepoint 2.0 services.  Sharepoint 3.0 services is not installed and thus .net 3.0 is not required.  My troubleshooting has deterined that the problem is not a Sharepoint issue as I've resinstalled and created separate application pools for .net 1.1 apps and .net 2.0 apps.  So the Line of Business .net 2.0 application no longer conflicts with the Companyweb.

No changes have been made to DNS from the default settings it was installed with.  
0
 
Jhall996Commented:
Did this problem ever get resolved ?

We are having the same problem. Had been working fine for a long time then all of a sudden various PCs on the LAN get the Welcome Page instead of CompanyWeb. Can happen on different PCs not always the same ones (Vista and XP) but can also work again the next day or even in a few hours. Apart from Windows updates, we have had no other recent changes.
0
 
Jhall996Commented:
Since no resolution has been posted, before this is closed I'll just add that the problem can be caused buy more than one DHCP running on the same Network which can in turn cause a DNS issue.
0

Featured Post

[Webinar] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now