Solved

Debugging - how can I prevent stepping into disassembly?

Posted on 2008-10-26
12
3,150 Views
Last Modified: 2013-11-20
How can I stop from stepping into disassembly when in debug mode?  I hit F11 - I just want to step into the function, not the disassembly...

I'm using Visual Studio 2008, C++

Thanks,
Mike
0
Comment
Question by:thready
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
  • 2
  • +2
12 Comments
 
LVL 12

Expert Comment

by:jazzIIIlove
ID: 22809638
Hi there;

http://blogesh.wordpress.com/2008/09/09/visual-studio-debugging-tips-and-tricks/
Please aim on:

Step 4 and 5...

Best regards...
0
 
LVL 1

Author Comment

by:thready
ID: 22809854
Hi Jazz,

Thanks for your response.  I'm using MFC, not .NET (unfortunately)....  And I'm looking for a way to always turn it off - not just for individual properties....

Mike
0
 
LVL 12

Expert Comment

by:jazzIIIlove
ID: 22809965
you want to step into MFC? right?

Visual Studio maintains a list of locations to look for library source files
when you are debuging. If this information gets corrupted or you press cancel to one of the dialogs
asking where source code is, you won't be able to step into MFC code.

You can view/edit the locations by right clicking on your solution, selecting properties and then "Debug Source Files". I think either deleting all the entries here or setting them to the correct values should
do the trick.

Best regards...
0
Business Impact of IT Communications

What are the business impacts of how well businesses communicate during an IT incident? Targeting, speed, and transparency all matter. Find out more in this infographic.

 
LVL 1

Author Comment

by:thready
ID: 22810057
I don't want to step into MFC.

If say in my code I have the following function call:
CString S;
MyFunction(S);

If when I'm on the MyFunction line in the debugger and I hit F11 (step into), I just want to step into my code.  But this is not what is happening - it goes into the disassembly...  Very annoying.  I just want to disable the disassembly stuff.........

I tried what you said in case, didn't work....

Thanks,
Mike
0
 
LVL 3

Expert Comment

by:Norbert
ID: 22819654
I am still working with 2005 so I am not sure if something important changed 2008 but normaly when that happens that means no symbols are loaded.

Is MyFunction inside a DLL?

Did you had a look to the output window? Is there some trouble reported about the symbol file?

If it is your own code did you try to set a break point inside the function?

Regards
Norbert
0
 
LVL 49

Accepted Solution

by:
DanRollins earned 500 total points
ID: 22853915
My work around is to use "Step Over" (F10 on my computer) as my default "single step" then when I get to a function that I want to step into, I use the other key.  
Also, if you acccidently step into ASM code, just hit "step out of"  (Shift+F11) and Robert's your papa's brother.
0
 
LVL 1

Author Comment

by:thready
ID: 22855195
Robert is my papa's brother???  I didn't catch that   :-) .....
0
 
LVL 49

Expert Comment

by:DanRollins
ID: 22859411
"Bob's yer Uncle" -- it's a British idiom (means something like "It's all good" :-)
0
 
LVL 1

Author Comment

by:thready
ID: 22861070
I like it - I'm gonna use it (most people around Montreal will look at me funny though)  :-)
0
 
LVL 1

Author Comment

by:thready
ID: 22861075
Your work around was my work around too....  I just hate having to even see ASM code and doing the shift-F11 every time to get out of it - because even when I do that, I have to right-click and say 'view source code' - to see a normal code listing again........
0
 
LVL 1

Author Closing Comment

by:thready
ID: 31510169
Oh well - I guess there's no other way to completely disable it - just step out of.....  answers my question!
0
 

Expert Comment

by:SchmidtZ28
ID: 23407462
I was having the same issue i think i found the best solution:

There is an option under the menu Tools/Options/Debugging/General. Make sure the "Show Disassembly If Source Is Not Available. setting is turned off.

You can also look at General, Debugging, Options Dialog Box on the MSDN site.
0

Featured Post

[Webinar] Code, Load, and Grow

Managing multiple websites, servers, applications, and security on a daily basis? Join us for a webinar on May 25th to learn how to simplify administration and management of virtual hosts for IT admins, create a secure environment, and deploy code more effectively and frequently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Visual Studio hangs on running project 6 83
Amazon S3 Images with .Net 3 62
Using the .NET JSON Serializer to create a single string 6 57
CSS styling problem 3 27
This article describes relatively difficult and non-obvious issues that are likely to arise when creating COM class in Visual Studio and deploying it by professional MSI-authoring tools. It is assumed that the reader is already familiar with the cla…
Many of us here at EE write code. Many of us write exceptional code; just as many of us write exception-prone code. As we all should know, exceptions are a mechanism for handling errors which are typically out of our control. From database errors, t…
This video will show you how to get GIT to work in Eclipse.   It will walk you through how to install the EGit plugin in eclipse and how to checkout an existing repository.
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question