removing Samba from RHEl5

HI all,
                I have installed RHEl5. I also have the licence.

when I try to run the comamnd

# yum update samba

it give the follwing error:

Transaction Check Error:   file /etc/samba/smb.conf from install of samba-common-3.0.28-1.el5_2.1 conflicts with file from package samba-common-3.0.25b-0.el5.4

I tried to remove the old one by command

# rpm -e samba-common-3.0.25b-0.el5.4

it says error: "samba-common-3.0.25b-0.el5.4" specifies multiple packages

can u please tell me how should i remove it so that the command
yum update samba can run

thanks in advance

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

http:// thevpn.guruCommented:

rpm --erase --allmatches samba-common-3.0.25b-0.el5.4
JATENDER1979Author Commented:
HI shakoush2001:

 when i run the command
#rpm --erase --allmatches samba-common-3.0.25b-0.el5.4

it gives the error

error: Failed dependencies: is needed by (installed) kdebase-3.5.4-13.6.el5.i386
        samba-common = 0:3.0.25b-0.el5.4 is needed by (installed) samba-3.0.25b-0.el5.4.x86_64
        samba-common is needed by (installed) system-config-samba-1.2.39-1.el5.noarch
        samba-common >= 3.0.8-0.pre1.3 is needed by (installed) gnome-vfs2-smb-2.16.2-4.el5.x86_64 is needed by (installed) gnome-vfs2-smb-2.16.2-4.el5.x86_64 is needed by (installed) kdebase-3.5.4-13.6.el5.x86_64

help please

http:// thevpn.guruCommented:

Try to remove those 3 packages above in the order mentioned
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

JATENDER1979Author Commented:

when i give the command
# rpm --erase --allmatches samba-3.0.25b-0.el5.4
it says

error: Failed dependencies:
        samba is needed by (installed) system-config-samba-1.2.39-1.el5.noarch
help please

http:// thevpn.guruCommented:
Ok try

rpm -e system-config-samba-1.2.39-1.el5.noarch


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JATENDER1979Author Commented:
hi shakoush2001:

I solved it anyway thankyou very much for your help.
I removed it in this fashion.

rpm -e --nodeps <package name>

thanks once again
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.