Solved

WebLogic startup error - Cannot make temp directory?

Posted on 2008-10-27
2
778 Views
Last Modified: 2013-12-12
We are having production environment with following configuration.

OS - Sun Solaris version:5.8

We are having one EAR file and one JAR file deployed in following location -
EAR File - BEA_HOME/user_projects/DOMAIN_NAME/applications
JAR File - BEA_HOME/user_projects/DOMAIN_NAME/common

We also have JAR file defined in our classpath defined in "startWebLogic.sh".

Currently we are facing following issue when we attempt to start the WebLogic.

<Oct 27, 2008 2:56:05 AM EDT> <Error> <HTTP> <101029> <[ServletContext(id=25258862,name=wl_management_internal1,context-path=/wl_management_internal1)] cannot make temp directory "/app/sos/prd005/bea/user_projects/ATDomain1/./ATServer1/.wlnotdelete/wl_management_internal1_wl_management_internal1_25258862", will not be able to compile JSPs>

We checked, we have all required files, EAR & JAR in their respective location and also have startup script proper. We are facing this issue even if we have no recent deployments. Please guide...
0
Comment
Question by:techprocess
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 19

Accepted Solution

by:
ramazanyich earned 500 total points
ID: 22821072
according to weblogic documentation from http://edocs.beasys.com/wls/docs81/messages/HTTP.html:
"BEA-101029
      

Error: [context] cannot make temp directory "path". Will not be able to compile JSPs.

Description
      Failed to create the temp directory with path: path for webapp: context.

Cause
      Temp directory creation failed.

Action
      Check the write permissions.
"

So probably user by which you have started your weblogic doesn't have permission to create files or folders on your path.
Check the directory permissions of weblogic installation.
And userid by which your weblogic process is started
0
 
LVL 10

Expert Comment

by:rajesh_bala
ID: 22827407
Can you delete the entire /app/sos/prd005/bea/user_projects/ATDomain1/./ATServer1/.wlnotdelete/ directory and restart the server?

Post if it doesnt work after this.
0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In our personal lives, we have well-designed consumer apps to delight us and make even the most complex transactions simple. Many enterprise applications, however, are a bit behind the times. For an enterprise app to be successful in today's tech wo…
This guide will walk you through the essential considerations and tech stack for building scalable websites. Know how to grow your business the smart way!
This video demonstrates basic masking and how to edit the mask to reveal the desired image.
Viewers will learn how to use the Hootsuite Dashboard.

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question