Solved

Windows Mobile won't connect to exchange with SSL

Posted on 2008-10-27
5
1,076 Views
Last Modified: 2012-05-05
Dear Experts,

Recently we installed SSL wild card cert from RapidSSL on our Exchange server. I tested OWA and HTTPS site works, I was able to succesfully connect the iPhone Gen2 devices to Exchange using SSL, however my Windows Mobile 6.1 (HTC Mogul with Sprint) will not connect no matter what I do.
I am not pushing the SSL from Exchange yet, but I did test with the option Require SSL from Exchange (still no luck). At first I had this issue with WM 6.0, so I then flashed the device and installed WM 6.1 but still having an issue. I tried setting it up wirelessly first and received; "Error synchronizing". Setting it up through Activesync on PC resulted in the same issue.

I also tried connecting to OWA from my phone through HTTPS:  then installed the cert, logged into e-mail, but after configuring e-mail to use SSL on the phone still having an issue.

Any help is greatly appreciated.

0
Comment
Question by:technomic
  • 3
  • 2
5 Comments
 
LVL 31

Expert Comment

by:Paranormastic
ID: 22816333
Don't use wildcards with exchange - that is your problem.  You will need to get a seperate cert - if you need to combine names use a UCC (multi-domain) cert instead in this case.
0
 
LVL 2

Author Comment

by:technomic
ID: 22822027
Paranormastic,

You maybe right that the wild card cert may cause an issue with WM devices while still working fine for iPhones. One of my consultants used the same cert for another one of their clients, but they didn't encounter these issues. Unfortunately, I can't purchase another cert right now and I need to get this resolved. Do you think there is a workaround to resolve this ?
I found the article below, I'm not sure if it will help...
http://support.microsoft.com/kb/915840
0
 
LVL 2

Author Comment

by:technomic
ID: 22822328
You maybe right, I did transfer the cert to device and installed it, but still having the same issues.
I also receive Support Code:85010016 when attempting to sync the device using ActiveSync.
0
 
LVL 31

Accepted Solution

by:
Paranormastic earned 500 total points
ID: 22823980
0
 
LVL 2

Author Closing Comment

by:technomic
ID: 31510467
i was able to finally resolve it. The cert did not properly instal on the WM device. At least it didn't display in the Intermediate Certs, I haad transferred the cert to the phone one more time and was able to install it and finally connected.

Thanks for your help.
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question