Solved

ASA 5505 Denying Internal Traffic

Posted on 2008-10-27
8
479 Views
Last Modified: 2012-05-05
I have posted my running config on my asa 5505 as well as error messages about denying traffic. Any help is appreciated.

Error messages:

Deny inbound UDP from 192.168.1.180/53 to FTPserver/63601 due to DNS Response

Deny inbound UDP from 192.168.1.180/389 to FTPserver/1412 on interface inside

Running config:

Result of the command: "sh run"

: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password encrypted
passwd  encrypted
names
name x.x.x.38 OutsideIP
name 192.168.1.154 FTPserver
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address OutsideIP 255.255.255.252
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns domain-lookup inside
dns server-group DefaultDNS
 domain-name default.domain.invalid
same-security-traffic permit inter-interface
access-list outside_access_in extended permit tcp any 192.168.1.0 255.255.255.0 eq ftp
access-list outside_access_in extended permit tcp any 192.168.1.0 255.255.255.0 eq ftp-data
access-list outside_access_in extended permit tcp any host OutsideIP eq ftp
access-list outside_access_in extended permit tcp any host OutsideIP eq ftp-data
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp deny any outside
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface ftp FTPserver ftp netmask 255.255.255.255
static (inside,outside) tcp interface ftp-data FTPserver ftp-data netmask 255.255.255.255
static (outside,inside) tcp FTPserver ftp OutsideIP ftp netmask 255.255.255.255
static (outside,inside) tcp FTPserver ftp-data OutsideIP ftp-data netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.37 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.129 inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:
: end
0
Comment
Question by:progonosko
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
8 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 22820947
In both error messages, both the source and the destination are local to the inside interface so the firewall can't do anything with it. You can ignore these error messages.
What does not work?
From the ASA console can you ping your next hop router? If yes, then what are you using for DNS? Internal dns server? You don't have any configured in the dhcpd scope.
0
 

Author Comment

by:progonosko
ID: 22821215
The problem is that when the FTPserver tries to browse the network, these messages come up, and that machine is unable to see the internal network. The initial messages that display (as above) are the FTP box trying to get to the internal DNS servers. I should have mentioned that this network has 2 gateways. The FTP is using one and the DNS servers are using the other.
0
 

Author Comment

by:progonosko
ID: 22827450
More points. Anyone?
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 79

Accepted Solution

by:
lrmoore earned 450 total points
ID: 22827629
If both the FTP server and the DNS servers are on the same IP subnet, they should still be able to talk to each other and you can still ignore these error messages.
Add this to the ASA
 sysopt noproxyarp inside

0
 

Author Comment

by:progonosko
ID: 22828096
lrmoore,

This seems to be working. Bear with me for a day or so so I can verify that it will work in production and I will give you the points. Thanks for your help. I'll throw in an extra 100 points if  you give me a brief explanation (or a link) as to why it works.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 22830592
0
 

Author Comment

by:progonosko
ID: 22846762
It's still working. As promised - 100 extra points. Thanks, lrmoore.
0
 

Author Closing Comment

by:progonosko
ID: 31510487
This completely cleared up the problem. Thanks, lrmoore.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
ip igmp join-group 8 73
Factory Reset of Juniper SSG20 2 42
Cisco Wireless Access Controller 3 35
Logging into A Cisco switch from another switch or router 2 31
I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question