?
Solved

Error enabling exchange certificate for IIS service

Posted on 2008-10-27
3
Medium Priority
?
5,894 Views
Last Modified: 2012-05-05
I have been having major problems getting an SSL certificate installed on my Exchange 2007 server.  I have successfully installed a test, 90 day trial certificate from comodo and tested external OWA and Activesync with my mobile devices.  However, since I also need internal DNS resolution, I purchased a UCC certificate.  Now I can't seem to enable the certifcate in Exchange.  I can enable it just fine for the services: POP, IMAP, and SMTP, however the service that I really need it for (IIS) returns an error.

When I enter this command in the managment shell:
Enable-ExchangeCertificate -thumbprint <thumbprint> -service IIS

I get this error:
Enable-ExchangeCertificate : An unexpected error occurred while the forms-based authentication settings for path /LM/W3SVC/1 were being modified.  The error returned was 5506.  At Line:1 char:27

I have contacted support at comodo, and searched EVERYWHERE online with no luck.  I'm pretty sure it has something to do with one of my IIS7 virtual directories, but I cannot find the solution to this one.  Any help would be GREATLY appreciated.
0
Comment
Question by:Jake Pratt
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 6

Expert Comment

by:Pret0rian
ID: 22819962
Hi,

Hav you tried to remove the certificate completly. And then import it again and so Enable it?

If that dosent work.....maybe re-isstall IIS

Remi
0
 

Author Comment

by:Jake Pratt
ID: 22822281
I have tried that several times, and not only restarting IIS, but rebooting the entire server.  No luck.  It still does this on all certificates.
0
 

Accepted Solution

by:
Jake Pratt earned 0 total points
ID: 22825539
Ok, I figured out why I was getting this message and fixed it.  All I had to do was go into IIS, and go to the bindings for my default website, and edit the 443 binding to use the certificate in question.  I didn't even need to re-enable it in the management shell after that.
0

Featured Post

When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question