Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4319
  • Last Modified:

Rigging with the skin modifier

Hello experts,

I've modelled a character and now need to rig him. I'm new to that unfortunately. I've already done the skeleton and all helpers and IK/FK setup. Now I need to assign my mesh to my bones using the skin modifier. Since it's a low polygon character I want to assign my vertices manually. The problem is, in the tutorial I'm following (Eva Wild series, rigging) the author moves the envelopes and the mesh moves along with the bones. When I do that it doesn't, my bone structure keeps moving but my mesh doesn't. And when I do it vertex per vertex it doesn't assign anything to my mesh.

I know it's probably a rookie question but I'd be really grateful if you could help me out.
0
Snapples
Asked:
Snapples
  • 2
1 Solution
 
bham3dmanCommented:
Hi Snapple,

When I assign vertex weights manually, I do the following:

1. Select a bone from the Bones list in the Skin modifier.  Any vertices that are weighted to the currently selected bone will have color (blue = low weight / red = high weight).  You might want to do this in wireframe mode - I have had some display issues in max 2009 in shaded mode.

2. Select any vertices that you wish to weight and then type in the desired weight in the Abs. Effect parameter and then press Enter. If you want to remove vertex weight completely, enter 0 as the Abs. Effect weight.

Note: When checked, the Normalize option forces the total weights (from all the bones it is assigned to) of each selected vertex to add up to 1.  So, if a vertex is weighted .4 to bone 1 and .6 to bone 2 - if you set the bone 1 weight to 0, the bone 2 weight will automatically change to a weight of 1.0.

There are many other ways to assign weights manually such as painting weights or using the weight table to change vertex weights in a spreadsheet fashion.

To sum up, if you select a bone from the Bones list and you see colored vertices that means you have vertices weighted to that specific bone.  You should then be able to move that bone in the viewport and watch those weighted vertices follow.  

I hope this is helpful.  I'd be happy to take a look at your max file if you like.


0
 
bham3dmanCommented:
A few other thoughts:

1.  Make sure your Skin modifier isn't turned off (lightbulb icon in modifier stack - white = on, gray = off).

2. Make sure your Edit Poly modifier/object below the Skin modifier has not been left in sub-object mode.  If so, the skin modifier will only affect the selected sub-objects (if any are selected).

3. If your vertices don't change color based on the size of your envelopes, the vertices are probably also weighted to another bone and the Abs. Effect setting is preventing them from being influenced further.  

4. Try opening the Weight Table and changing the drop-down list value to "Selected vertices".  Then select vertices in the viewport and those vertices will be shown in the Weight Table.  You will then be able to tell which bones the vertices are weighted to.
0
 
SnapplesAuthor Commented:
I think it was one of the last 3 reasons you posted, I checked those so that it matched your explanation and now the mesh moves as well.
Thank you.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now