• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 773
  • Last Modified:

New cluster via MSCS, no quorum

Hi,

I am trying to setup a MSCS and it is really driving me crazy; for some reason, it just does not want to see the quorum.

I have tried running it in full mode as well as in minimal mode. Server is attached to SAN.

I was able to see the two (out of three) shared drives initially, but they could not be brought online and the cluster service ended up creating local quorum. Event 1069, "Cluster resource 'Disk Q:' in Resource Group 'Cluster Group' failed.". Same for the other disk.

I tried to evict the node afterwards and create a completely new cluster, new name, new IP... and now it does not even see the disks anymore.

Resource configuration:
       Local Quorum - Managed - Quorum
       Majority Node Set - NOT managed

It does not see anything else...

Any ideas, maybe?
0
mmilic
Asked:
mmilic
  • 3
1 Solution
 
mmilicAuthor Commented:
I have found an article on Microsoft.com which explains why this problem is happening:

http://support.microsoft.com/kb/886807

Now I only need to figure out which other latest service pack to install when there is SP2 already...
0
 
mmilicAuthor Commented:
http://support.microsoft.com/kb/259267/

"For MSCS to recognize a disk as a shared disk, the disk must be on a controller that is separate from the adapter of the operating system's boot disk."

Any thoughts on this? Surely there must be a workaround for this.
0
 
65tdCommented:
What accout is the cluster service running under, does it have full NTFS rights to the SAN disks?
0
 
mmilicAuthor Commented:
For anyone who ends up having the same problem... apply the below, it works like a charm.

1.      Click Start, click Run, type regedit, and then click OK.
2.      Locate and then right-click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ClusDisk\Parameters
Note If the Parameters registry subkey does not exist, right-click ClusDisk, point to New, click Key, type Parameters as the subkey name, and then press ENTER.
3.      On the Edit menu, point to New, and then click DWORD Value.
4.      Type ManageDisksOnSystemBuses as the entry name, and then press ENTER.
5.      Right-click ManageDisksOnSystemBuses, and then click Modify.
6.      In the Edit DWORD Value dialog box, click Decimal, type 1 in the Value data box, and then click OK.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now