• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8300
  • Last Modified:

Hyper-v Guest OS Failed to start - Failed to create memory contents file...

Host Machine:
I Server 2008 x64 SP1
37GB free on drive C: and 369GB free on Drive D:
12GB RAM

Guest OS:
Server 2003 SP2 x86.

Installed fresh a week ago and just all of a sudden, I cant get it to even boot up.

It gives me an error:
An error occurred while attempting to change the state of virtual machine McAfee
'McAfee' failed to initialize.

Failed to create memory contents file 'F:\ProgramData\Microsoft\Windows\Hyper-V\Virtual Machines\....(some numbers)...\..morenumbers.bin' of size 2048MB.

I have seen about every article on the net (that I know of )about fixing the problem, but so far no real luck.
It seems to be a lack of memory issue, because the MOST RAM I can allocate to the guest OS for a successful startup is 25MB - hardly suitable.. It originally had 2048MB.

I have tried disabling the Page file on drive C, and putting it only on D. I tried making both a smaller and larger custom size page file on C:. - No Luck.. Once again, now it only boots when I allocate 25MB to the guest OS.. The SAME VHD boots fine using Virtual Server 2005 though...

Here is my Physical Memory Info:
Physical Memory(MB)
Total:     12282
Cached: 1413
Free:      8549

VM-error.jpg
0
romerica
Asked:
romerica
2 Solutions
 
brent_caskeyCommented:
You need to free up more space on the D: drive. The error message above states that it cannot create the memory contents to the d:\programdata....

Try to free up 2+GB on the D: and try to restart the system again.
0
 
tomtownCommented:
I agree with brent, but you might check that the permissions on D:\ProgramData\Windows\Hyper-V\McAfee.. are set correctly (System account at least Change access, i'd try everyone change for a try)
0
 
tomtownCommented:
Oh, and if this is all good, i'd try to localize the file the error specified and rename it to something like %thatlongID%.bin_old
0
 
romericaAuthor Commented:
Ok, so it was a combination of Disk Space AND permissions. Im glad both of you responded..

Problem was, I HAVE plenty of disk space (369GB free). BUT - I had quota management enabled and set to DENY requests for people exceeding their quota..

After that, I got a different error message about security permissions, so I went in and gave EVERYONE Full Control to both the Hyper-V and McAfee directories. After that, all was well!

So when it says it has a problem creating "memory", it doesnt mean Physical RAM? I guess it means Disk Space..

Thanks!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
0
 
SydtechCommented:
The solution is definitely correct.  We had a virtual machine--one hosting a pre-production test environment for a a critical custom database--fail to start and give us the error message posted above.  There was only 1 GB of space on the vm's D:/ drive.  We moved about 18GB of files off it and restarted the vm just fine.  Thanks to Brent's solution, we saved considerable time in researching the problem.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now