Solved

Difficulty Upgrading to Larger Hard Drive in HP D530 Desktop

Posted on 2008-10-27
11
1,601 Views
Last Modified: 2016-06-26
I have been unsuccessful in trying to upgrade the original Maxtor 40GB HD in my HP D530 business desktop to a Western Digital 160GB HD.  The BIOS automatically recognizes the new drive when I install it, but the system will not boot from a WINXP CD to load the operating system, even when the boot order is set to the CD Drive option.  I typically get either a "NTLDR is Missing error" or the system attempts to boot from the CD, but then halts with a "Bad Disk" error.  Using the Western digital Lifeguard tools, I can reformat the new drive and prepare it for Windows XP, but the same failures occur.  If I remove all HDDs , the system boots into the Windows XP setup from the CD just fine, except that it has no drive to install the OS on.  

I have also attempted to clone the existing 40GB drive onto the 160GB Drive which, by all indications goes through successfully, but when I remove the 40GB drive and make the 160GB drive the primary, I get a "NTLDR is missing error".  I have tried this using partitions larger than 37GB and partitions smaller than 30GB, to no avail.

I have verified that the hard drive jumpers are set to cable select and even went so far as to reset the CMOS and BIOS password jumper.  Nothing seems to be working to get the system to work with the new hard drive.  

Also, another oddity, not sure if this is related but thought I should mention it, I cannot get into the system's BIOS setup when hitting F10 at startup.  I can get to the F9 boot sequence screen though.  

Something is not right somewhere, but I can't seem to pin this one down.  Any suggestions for things to try would be appreciated.
0
Comment
Question by:Intech_IT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
11 Comments
 
LVL 39

Expert Comment

by:PUNKY
ID: 22818888
How did you clone the drive?
- copy disk to disk
- copy mbr
- set active
- do not assign drive letter
0
 

Author Comment

by:Intech_IT
ID: 22818965
I used Drive Clone Home Ver. 5 from Farstone.  I have used this technique on other systems without any issues or modifications to the default settings.  
0
 

Author Comment

by:Intech_IT
ID: 22818972
Also, I have tried cloning with the new drive attached via a USB external HDD Enclosure and then a second time attached to the secondary IDE connector on the MB.  
0
 
LVL 26

Expert Comment

by:akahan
ID: 22819084
I guess I have a theory....and the first question is, are you using a USB keyboard?...maybe you
see where I'm going with this...
0
 
LVL 92

Expert Comment

by:nobus
ID: 22819647
try setting the drive as master - or slave, instead of cable select (and the cd drive too)
0
 
LVL 11

Expert Comment

by:jgmontgo
ID: 22820387
You mention a very imporntant clue here "Also, another oddity, not sure if this is related but thought I should mention it, I cannot get into the system's BIOS setup when hitting F10 at startup.  I can get to the F9 boot sequence screen though."
I am wondering if we have a problem with the BIOS not supporting that hard drive, or some other oddity that is causing this. So a couple of questions:
  1. I assume the original drive was PATA, is this correct?
  2. Is the replacement drive SATA or PATA?
  3. If the drive is SATA is it SATA-I or II?
  4. If it is SATA what connector is it connected to (should be SATA 0 according to HP)
Here is a link to the Hardware Reference:
http://bizsupport.austin.hp.com/bc/docs/support/SupportManual/c00059123/c00059123.pdf
I am wondering if this is related to the drive and how it is installed. If the original was set to Cable Select, you should use the same connector on the cable and set the new drive to Cable Select. If you are using SATA, make sure you connect to the SATA 0 connector and initially try SATA-I 1.5 Gbit/s, then try SATA-II 3.0 Gbit/s.
Pay special attention to how the original drive was setup and how the replacement is.
I checked the BIOS version history and saw nothing to indicate an issue, so BIOS update is not warranted. However, the fact that you are experiencing some difficulty in getting into the BIOS with this drive installed may be a clue.
0
 

Author Comment

by:Intech_IT
ID: 22820647
I am using a standard PS2 keyboard and mouse.  The old drive is a PATA and the new drive is a PATA. I have updated the BIOS to the latest version available, ver 2.43 I believe, but that had no impact on the BIOS access issue.  I just tried to use the drive as a secondary/backup drive, connected via a USB enclosure, and the strange thing is, the BIOS recognized the drive.  I was able to format the drive in Windows and subsequently was able to R/W any amount of data to it.  Is it possible that in order for the drive to become a bootable drive, this HP system requires some sort of hidden partition on the drive that my cloning program isn't seeing?  I found fleeting references to such a thing, but no concrete steps on how  to set that up on the new drive.  
 
0
 
LVL 11

Accepted Solution

by:
jgmontgo earned 250 total points
ID: 22828802
I am really seeing nothing with the computer or BIOS that should be causing this.
I do have an idea that might work. There is a program that I love for cloning hard drives that I would love to see you try. This program will clone everything including the MBR and any special partitions.
Here is a link to the product:
http://www.acronis.com/homecomputing/products/migrateeasy/
They do offer a free 15 day trial, way more than enough time to see if it will work for you. You can click on the Download Free Trial button or the link below:
 http://www.acronis.com/homecomputing/download/migrateeasy/
You should be able to reinstall the 40GB drive as the Master, the 160GB as a slave (they should support USB if you need to keep it as an external drive). It will copy everything and resize the partitions appropriately.
I am thinking it might be an issue with the software you were using to clone the disks with. Acronis® Migrate Easy 7.0 is a great product and should work well for you.
0
 

Author Comment

by:Intech_IT
ID: 22847431
Thanks jgmontgo! I downloaded the acronis software and that seemed to do the trick.  I connected the new drive up to the secondary IDE connector and teh software cloned the primary drive without much effort.  I moved the new drive to the primary and everything booted right up.  Thanks again.  
0
 

Author Closing Comment

by:Intech_IT
ID: 31511938
Thanks for the help.  
0
 
LVL 11

Expert Comment

by:jgmontgo
ID: 22847865
Very nice! I am happy to hear that it worked well for you!
Thanks for the points!
0
Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
Employees depend heavily on their PCs, and new threats like ransomware make it even more critical to protect their important data.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question