Solved

Internet Explorer cannot display the webpage, Google, Gmail, Youtube, Firefox home page, Live.com, Msn and possibly more sites more won't load

Posted on 2008-10-27
33
13,111 Views
Last Modified: 2013-12-09
I suddenly just had this problem where Google.com, Google.ca Youtube.com, Youtube.ca, Live.com, Live.ca, Msn.com, Msn.ca and possibly more sites ( I just haven't tested each site out yet ) fail to load. The wierd thing is - these sites were all loading for me this afternoon and I haven't installed anything or deleted anything or changed anything since then.

It seems that everything that is related to Google will not load on my browser. I have tried 5 different browsers and this problem will not go away.

---------------------------------------------------------
Message shown:

The address is not valid
   
   Most likely causes:
There might be a typing error in the address.
If you clicked on a link, it may be out of date.
 
   What you can try:
     Retype the address.  
 
     Go back to the previous page.  
---------------------------------------------------------

NOTE: Yahoo will load | Many other sites will load | I do have a firewall (password protected, forgot password) but I do not remember blocking google OR msn | I have already read about hosts file, and I have tried entering google.com + ip address - does not work.

PS google.co.uk works?!? but just not the others? could it be a problem with my ISP?

Soo yeah, this is really frustrating and scary at the same time.
If anyone could help me resolve this problem I'd appreciate it greatly!

Thanks,
Jason
0
Comment
Question by:JCDu
  • 19
  • 8
  • 3
  • +3
33 Comments
 
LVL 26

Expert Comment

by:akahan
Comment Utility
Have you checked your hosts file?
0
 

Author Comment

by:JCDu
Comment Utility
Yes I have
0
 
LVL 26

Expert Comment

by:akahan
Comment Utility
First thing to figure out is whether it's your machine, or your ISP, or your ISP's DNS servers.  

Do you have another PC you could try, utilizing the same connection to determine whether it's a setting in your PC?

Alternatively (this is not QUITE as good), can you create a new user account on your existing PC, and try surfing to those sites from that account?  

To rule out your ISP's DNS servers, try manually setting your PC to use a different set of DNS servers - for example, those at opeDNS:  208.67.220.220 and 208.67.222.222

0
 

Author Comment

by:JCDu
Comment Utility
Alright, so I tested it out on another computer in the house. It seems like it might be a problem with my machine. Google.com works on the other computer.

As for ISP DNS server, I have no idea how you manually set the PC to use a different set of dns server.

However, it seems like it doesn't have anything to do with my ISP since the other computer will load the page.
0
 
LVL 26

Expert Comment

by:akahan
Comment Utility
Good, the problem is being narrowed down.

Since your other computer will load these pages, we know, as you say, that it's not your ISP.  So the next step is to determine whether it's DNS-related.  To find out, get the NUMERIC IP address for one of the problem sites.  You can do this by using the WORKING computer to ping one of the problem sites, by opening up a command prompt, and typing, for example:

ping www.google.com

You'll get a numeric IP address, something like 208.67.219.230

Now, go to the problem-child machine, and, in your browser, enter http://208.67.219.230 (or whatever IP address your working machine gave you for google.)

If you get the google homepage, then the problem is DNS related, and we know where to go next.  If you don't, then it's more likely malware related.
0
 

Author Comment

by:JCDu
Comment Utility
Alright I did this and it lead me to Google English. However when I try to type anything in and press Search, it will lead me back to the same "Internet Explorer cannot display the webpage" page.
0
 
LVL 26

Expert Comment

by:akahan
Comment Utility
So it is sounding DNS-related.  If you go to
Control Panel/Network Connections, select your connection, and right-click on it, and choose Properties,
then select Internet Protocol TCP/IP, and click the Properties button, what do you see in the lower box, the one talking about DNS servers?
0
 

Author Comment

by:JCDu
Comment Utility
Hmm.. see attatched picture
screen1.jpg
0
 
LVL 26

Expert Comment

by:akahan
Comment Utility
Go to advanced, and delete that 0.0.0.0 default gateway (by clicking the Remove button)  so that default gateway is blank, instead of zeroes.  That would pretty much be your problem, I think.
0
 

Author Comment

by:JCDu
Comment Utility
Also just to add, for some sites I visit it shows a really messed up page + images don't load.

For example if I go to Flickr.com, or search something on yahoo, the result is a web page without any order, like theres no stylesheet or something. It just shows a white page with alot of links instead of showing the nice background and link colors, font, etc. It started around the same time google started not to work, so are these two things perhaps related? Malware? Virus? ( probably not becuase I just scanned my computer, no virus found ) Spyware?

Jason
0
 

Author Comment

by:JCDu
Comment Utility
Sorry to say - but it didn't work. It still shows up with the internet explorer cannot be displayed
0
 
LVL 26

Expert Comment

by:akahan
Comment Utility
With your default gateway set to zeroes, I'm surprised that you're getting out on the net at all...It may be that all you're seeing is portions of webpages that are cached on your system, from previous visits.  See what happens when you get rid of those zeroes...
0
 
LVL 26

Expert Comment

by:akahan
Comment Utility
Then it's sounding like malware or spyware, or you're screwing yourself with over aggressive firewalling (like what Spybot or Zonealarm does sometimes).

0
 

Author Comment

by:JCDu
Comment Utility
Uh oh, when i remove the 0's nothing else works at all. I'll be suprised if i can even post this comment.
0
 

Author Comment

by:JCDu
Comment Utility
How do I add back the 0's because it won't allow me to?
0
 

Author Comment

by:JCDu
Comment Utility
And i can no longer refresh this page or else it won't load and I'll be screwed over for good.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:JCDu
Comment Utility
and I think I have to post to see the updates
0
 

Author Comment

by:JCDu
Comment Utility
This is extremely wierd .. I can ONLY refresh experexchange.com. All my other web pages when I refresh they turn into the "Internet cannot display ... " page
0
 
LVL 4

Expert Comment

by:majidhajali
Comment Utility
1) first go to start | Run and type:
 ping yahoo.com
if you get a message like
Reply from 69.147.76.15: bytes=32 time=331ms TTL=42
it's ok with your connection and go to step 2.
otherwise check your modem, connection properties and other things and make sure your ISP doesn't have any problem.
2) Open Internet Explorer, go to Tools, manage add-Ons and disable any add-on which installed by third party vendors. clear your history and delete all the files, cookies and etc.
It may work.
ping yahoo.com

Open in new window

0
 

Author Comment

by:JCDu
Comment Utility
Hmm it says Request timed out.
You know what, this is what I'm going to do and I'll see if it works or not.

I'm going to 1) system restore and then 2) unplug/replug my modem.

I'll be back in a bit with the results.
0
 
LVL 4

Expert Comment

by:majidhajali
Comment Utility
do you access the internet from the same copmuter which got request timed out??
0
 

Author Comment

by:JCDu
Comment Utility
Yeah
0
 

Author Comment

by:JCDu
Comment Utility
Okay, be right back doing system restore

Jason
0
 

Author Comment

by:JCDu
Comment Utility
Okay.. nothing happened. But at least I can go to google.co.uk now ......
0
 

Author Comment

by:JCDu
Comment Utility
NOTHING HAPPENED ... any suggestions / possible solutions would be appreciated? Raising point value .. I'm tired
0
 
LVL 4

Expert Comment

by:majidhajali
Comment Utility
switch to firefox. it's safer, quicker and more convenient than IE. ;)
did you try clean your cookies, offline files, history and disable any additional add-Ons?
0
 

Author Comment

by:JCDu
Comment Utility
@Majidhajal

I tried using 5 different browsers.. and none of them work. I think its something blocking my connection to these sites, but I can't access my firewall since I forgot my password to it.

If there's anyway to get rid of the password to the firewall I could check to see if it really is the firewall's problem.

PS IM USING COMMODO FIREWALL + WONT LET ME UNINSTALL WITHOUT PASSWORD / CHANGE ANYTHING OR EVEN ACCESS IT WITHOUT A PASSWORD ANYHELP
Jason
0
 

Author Comment

by:JCDu
Comment Utility
Okay uhm, going to sleep for today.. I'll check back tomorrow
Many thanks guys ..

Bye
Jason
0
 
LVL 26

Accepted Solution

by:
akahan earned 300 total points
Comment Utility
Ideally, you'd want to uninstall Commodo firewall.  If you can't, because of no password, will it let you REINSTALL it, and, in the process, use a new password?
0
 

Author Comment

by:JCDu
Comment Utility
You know what, I'm going to reformat my computer .. just so if there's any problems with WHATEVER - it will be solved. Thanks alot guys for your time but mostly to akahan since he tried to help me out the most.

Jason
0
 
LVL 2

Expert Comment

by:esa_esa_2000
Comment Utility
First try to ping Google.com this will say what about your DNS service and firewall and networkpath if this success then it will be matter of browser if it didn't i will provide you with IP of google to be test if it succeded then it was proplem of DNS if not then it was problem of network or firewall ......
0
 

Expert Comment

by:llbennett
Comment Utility
I have the same problem.  I can ping Google.com.  How do I fix my browser.
0
 
LVL 1

Expert Comment

by:ctsmequon
Comment Utility
To future users who may find this information helpful:

After an apparently successful malware cleaning session with Malwarebytes, I was still having the IE8 connection problem similar to (but not quite the same as) this post. In my case, I couldn't get to any websites, but I could ping from a command prompt with no problems. Also, no other PCs on my network were having connection problems. I performed the suggested "IE8 | Tools | Internet Options | Advanced | Reset | Reset" and that did not correct the problem. However, for reasons passing comprehension, doing a reset of IE8 DID NOT RESET THE PROXY SETTINGS. Looking in "IE8 | Tools | Internet Settings | Connections | LAN Settings" I saw that the "Use a proxy server... " box was still checked. My location does not use a proxy server. Clicking on the Advanced button, I saw that the HTTP Proxy address to use was 127.0.0.1. Of course, this is the localhost and will never produce web page results (just a final FU from the malware authors).
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Several part series to implement Internet Explorer 11 Enterprise Mode
Envision that you are chipping away at another e-business site with a team of pundit developers and designers. Everything seems, by all accounts, to be going easily.
This tutorial demonstrates how to identify and create boundary or building outlines in Google Maps. In this example, I outline the boundaries of an enclosed skatepark within a community park.  Login to your Google Account, then  Google for "Google M…
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now