Solved

Switch to Router Connectivity issues

Posted on 2008-10-27
9
1,622 Views
Last Modified: 2012-05-05
Hey all, im in a situation where i have 2 switches, connected to the same router, routing the same vlans.  Now i have bridge groups connecting my 2 switches to the router for redundancy.

c7000----------SWITCH1----------ROUTER
        ^---------SWITCH2---------^     <--connected to same router

when i enable the port on switch1 connected to the router to start working, it works fine, the router routes between vlans fine all is good.  But when i enable the port on switch2 connected to the router to start working, if all works fine for about 30secs then they both disable and stop working.  When i do "Sh int" for the ports connecting to the router it says "DISABLED-ERR".  How do i get both switches working/routing the same vlans??
The aim is to route all data from the c7000 ova either switch for redundancy and back either path.  The Hardware setup is correct.  Attached is the switch and router config.
ANY HELP WILL BE REALLY APPRECIATED!
no aaa new-model

switch 1 provision ws-c3750g-24ps

switch 2 provision ws-c3750g-24ps

system mtu routing 1500

ip subnet-zero
 

!
 

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface Port-channel1

 description TO ROUTER

 switchport trunk encapsulation dot1q

 switchport mode trunk

 flowcontrol receive desired

 spanning-tree portfast trunk

!

interface Port-channel2

 description UPLINK_VC_A

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 spanning-tree portfast trunk

!

 description UPLINKVC_B

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 spanning-tree portfast trunk

!

interface Port-channel4

 description UPLINK_VC_C

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 spanning-tree portfast trunk

!

interface Port-channel5

 description UPLINK_VC_D

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 spanning-tree portfast trunk

!

interface GigabitEthernet1/0/1

 description VC-B1-1

switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 2 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet1/0/2

 description VC-B1-2

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 2 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet1/0/3

 description VC-B2-1

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 3 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet1/0/4

VC-B2-2

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 3 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet1/0/5

 description VC-B3-1

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 4 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet1/0/6

 description VC-B3-2

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 4 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet1/0/7

 description VC-B4-1

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 5 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet1/0/8

 description VC-B4-2

 switchport access vlan 10

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 5 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet1/0/9

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet1/0/10

 switchport access vlan 10

switchport mode access

!

interface GigabitEthernet1/0/11

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet1/0/12

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet1/0/13

 description TAPE_iLO

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet1/0/14

 description EVA_WEB_OCP

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet1/0/15

 description OA_c7000_RIGHT

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet1/0/16

 description Brocade_FB

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet1/0/17

 description MGMT_SERVER_NIC_1

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet1/0/18

 description c7000_UPS_MGMT_UPPER

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet1/0/19

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet1/0/20

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet1/0/21

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet1/0/22

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet1/0/23

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet1/0/24

 switchport access vlan 10

 switchport mode access

interface GigabitEthernet1/0/25

!

interface GigabitEthernet1/0/26

!

interface GigabitEthernet1/0/27

 description LINK_PatchingRoom

!

interface GigabitEthernet1/0/28

 description ROUTER

 switchport trunk encapsulation dot1q

 switchport mode trunk

 flowcontrol receive desired

 channel-group 1 mode on

!

interface GigabitEthernet2/0/1

 description VC-B1-3

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 2 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet2/0/2

 description VC-B1-4

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 2 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet2/0/3

 description VC-B2-3

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 3 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet2/0/4

 description VC-B2-4

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 3 mode active

 spanning-tree portfast trunk
 

interface GigabitEthernet2/0/5

 description VC-B3-3

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 4 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet2/0/6

 description VC-B3-4

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 4 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet2/0/7

 description VC-B4-3

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 5 mode active
 

!

interface GigabitEthernet2/0/8

 description VC-B4-4

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 10,11

 switchport mode trunk

 channel-group 5 mode active

 spanning-tree portfast trunk

!

interface GigabitEthernet2/0/9

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet2/0/10

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet2/0/11

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet2/0/12

switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet2/0/13

 description Brocade_Swch_FA

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet2/0/14

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet2/0/15

 description EVA_UPS_MGMT

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet2/0/16

 description EVA_UPS_MGMT_2

 switchport access vlan 10

switchport mode access

!

interface GigabitEthernet2/0/17

 description MGMT_SVR_NIC2

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet2/0/18

 description c7000_UPS_MGMT_LOWER

 switchport access vlan 10

 switchport mode access

 spanning-tree portfast

!

interface GigabitEthernet2/0/19

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet2/0/20

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet2/0/21

switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet2/0/22

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet2/0/23

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet2/0/24

 switchport access vlan 10

 switchport mode access

!

interface GigabitEthernet2/0/25

!

interface GigabitEthernet2/0/26

!

interface GigabitEthernet2/0/27

!

interface GigabitEthernet2/0/28

 description ROUTER

switchport trunk encapsulation dot1q

 switchport mode trunk

 flowcontrol receive desired

 channel-group 1 mode on

!

interface Vlan1

 no ip address

!

interface Vlan10

 ip address 10.112.234.13 255.255.255.0

!

ip default-gateway 10.112.234.1

ip classless

ip route 0.0.0.0 0.0.0.0 10.112.234.1

ip http server

!

Open in new window

router.TXT
0
Comment
Question by:Thunder-Cat
9 Comments
 
LVL 16

Accepted Solution

by:
Aaron Street earned 500 total points
ID: 22819801
try a show log

this will tell you why the port it err disabeling

 there are a few resons

you can do a show err-disable detection (i think it detection but try sh err-disabble ? to check)

that will show you what things are monitored for err-disable.

I would guess it might be that the switch is seeing the same mac address on two ports, so it will shut one down.
but a show logs will tell you what has happened.

also dont reboot the switch, You will lose the logs (unless you have set them up to save to non volitila memory or to soem where off the switch!
0
 
LVL 16

Assisted Solution

by:Aaron Street
Aaron Street earned 500 total points
ID: 22819835
It jsut so happend I have a nice example of a BPDU insidence on one of my switchs causing a err-disablable. As you can see in the show log below, it sees a violation of the BPDU and disababels the port.

also hear a link to some more about err-disabables

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a00806cd87b.shtml

if you cant get to that link let me know and I will get a copy for you
3750 switch#show log

Syslog logging: enabled (0 messages dropped, 0 messages rate-limited, 0 flushes,

 0 overruns)

    Console logging: level debugging, 129 messages logged

    Monitor logging: level debugging, 0 messages logged

    Buffer logging: level debugging, 129 messages logged

    Exception Logging: size (4096 bytes)

    File logging: disabled

    Trap logging: level informational, 130 message lines logged
 

Log Buffer (4096 bytes):

UARD: Received BPDU on port FastEthernet1/0/4 with BPDU Guard enabled. Disabling

 port.

*Apr 18 00:02:06.410: %PM-4-ERR_DISABLE: bpduguard error detected on Fa1/0/4, pu

tting Fa1/0/4 in err-disable state

*Apr 18 00:02:07.417: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern

et1/0/4, changed state to down

Open in new window

0
 

Author Comment

by:Thunder-Cat
ID: 22820263
Hey thanks for the reply :) interesting what your saying,im not at work atm so cant try the show log command which i will do but i remember when the error came up it says that, "po1 port is flapping with port such and such ( afair few different ports) and then displays mac addresses and when i do "sh bridge" no mac addresses appear.
0
 
LVL 16

Expert Comment

by:Aaron Street
ID: 22820438
in which case it is simple that is it seeing a mac addrss jumping between ports.

this may be due to having portfast turned on on the switch, (oh i noticed your other question ;) ) see my reply there..

no no no portfast on switch to switch links!! this will be the problem. Post-fast assumes a single device connected to the port. when you connect another switch it is seeing more than one mac address. it will nto liek that and think there is an error..

turn of portfast and i bet it will be fine.
0
Save on storage to protect fatherhood memories

You're the dad who has everything. This Father's Day, make sure your family memories are protected. My Passport Ultra has automatic backup and password protection to keep your cherished photos and videos safe. With up to 3TB, you have plenty of room to hold the adventures ahead.

 
LVL 21

Expert Comment

by:from_exp
ID: 22820485
btw, take a look here http://h20000.www2.hp.com/bc/docs/support/SupportManual/c01386629/c01386629.pdf
about how to connect VCs to cisco switch
0
 

Author Comment

by:Thunder-Cat
ID: 22827197
Ive disabled portfast on all ports and still no joy.  I have a channel-group configured on the switches to goto the router, now do i need one to go back to the switches??
0
 
LVL 16

Expert Comment

by:Aaron Street
ID: 22829135
if you have a duel link, then you will need to either set up spanning tree to block on of the ports. Or set up a port channel group.

if you turn of spanning tree, and done have a channel group on a duel link you will get probelms. no matter where the linsk are comming to or from..
0
 

Expert Comment

by:microIT
ID: 24234733
I know this is old and closed but I want to ask a question related to this, I understand if it can't be answered in the same thread but thought i'd try anyway.  Is portfast OK on a switchport connected to a router?  Will it cause any issues (i.e. performance, etc)?
0
 
LVL 16

Expert Comment

by:Aaron Street
ID: 24239558
no.

portfast is simple telling the port to skip spanning tree checks, and put the port directly in to a forwarding state. It has no affect on the actuly proformance of the link.

The only issue you may have is that if you create a loop in the network with ports that are port fast! Spanning tree will not then block them and you can will have issues. but if you are carefull then there is no reson no to have portfast enababled.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Hello All, I have been training on Multicast for a while now and whenever I start the topic , I find out that my friends /  Colleagues mention that they do not know how to test Multicast Joins. As most of the multicast would be video traffic and …
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

919 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now