Switch Flapping

Hey all i have 2 switches which are both onnected to a router, and the router is configured with bridging to provide redundancy.  Now the problem is, when i 'no shut' both ports on the router connected to the switches, it all works well for 20secs and i can even ping succesfully, but then is comes up saying that the po1 port is flapping with port such and such and then both ports goto into err-disabled mode. I was wondering how i get around that??  Or is there another way to try and get 2 ports on the same router to be able to use the same default-gateway.

Cheers
Thunder-CatAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

from_expCommented:
possibly you have created a loop within your network.
do you have spanning tree enabled?
what is your network topology?
0
Thunder-CatAuthor Commented:
hey thanks for the reply, the topo is a c7000 connected to a router via two switches in parallel for redundancy and the trunk ports from the switches to the router have spanning-tree portfast trunk enabled.  when i type "sh bridge" on the router no mac addresses appear.
0
Aaron StreetInfrastructure ManagerCommented:
you dont want port fast!!!

that shoudl only ever be used on access ports to connect host devices to!!

never switch to switch ports!
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

from_expCommented:
hmmm, spanning tree port fast should be disabled on non-end ports....
if c7000 is hp blade chassis, then what kind of network modules do you have?
0
Aaron StreetInfrastructure ManagerCommented:
ps see your other question.

0
Thunder-CatAuthor Commented:
I figured it out i ended up taking port-channelling off the switchports going to the router and it stopped flapping.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.