Solved

Cannot Pass Database Login Info when Opening Crystal Reports

Posted on 2008-10-28
8
1,626 Views
Last Modified: 2013-11-15
Hi,

I just recently installed Crystal Reports Enterprise Server XI R2 on a Windows 2003 SP2 Server using a sql 2005 express database instead of the canned mysql. I am trying to free up my sql 2000 licenses by using the free version but not having luck so far.

Whenever I go to open a crystal report on a sql server, i am prompted with a login prompt. I went into the business view manager and set the data connections to never prompt and took the defaults when publishing the report "to prompt user for database login", but  i am still getting the login prompt. The login credentials to the CMS database are the exact same as the credentials used on the sql server. I am at wits end here, not sure what else to try. I would hate to have to go back to the sql 2000. I am just wondering if sql 2005 express does not work with this version of crystal. TIA
0
Comment
Question by:beargonefishing
  • 5
  • 3
8 Comments
 
LVL 11

Expert Comment

by:Rob132332
ID: 22824697
Hi - How are you testing the actual running of the Crystal Report?  And, what version of Crystal Reports is the report created in?
If you're in the Crystal Management Console, try entering the password, clicking Update at the bottom of the page, then back on the Properties tab of the Object, click Update again, then click Preview.  
Do you get a request for a password?
0
 

Author Comment

by:beargonefishing
ID: 22824760
I am testing from the crystal management console itself. The reports were most likely created in version 9 and were imported using the import wizard from another crystal test server to this one. The one i am currently working on now is going to be the permanent one, i just have it on another test server so there is no interruption to the users during the migration

I tried all those steps and it still prompts for db login info.  I even created connections in the business view manager and set it to not prompt and it still does.
0
 
LVL 11

Expert Comment

by:Rob132332
ID: 22824822
Wow, interesting.
Which option is checked on the Process, Database tab?  "Use original database logon information from the report" or "Use custom database logon information specified here"
And, is there only one Data Source?  If there are more than one, you have to set each password separately, but you probably have checked that already.
 
And, "Prompt the user for database logon when viewing" should be unchecked, correct?
If all of that checks out, and since it sounds like this is a test environment, reset the password at the database, rekey it into Crystal Management Console, and try it again.  
To test that the password is working, you could connect to the database using any ODBC connection (Access, SQL Tools), and use the login credentials you'll be resetting in the suggestion above.  
 
0
 

Author Comment

by:beargonefishing
ID: 22824868
"Use original database logon info" -checked
one data source
"prompt the user for database logon"-checked (this option should be checked)

going to try resetting database password and rekeying. i will let you know how it goes



0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 11

Assisted Solution

by:Rob132332
Rob132332 earned 100 total points
ID: 22824937
Hi - checking "Prompt the user for database logon when viewing" is why you're getting the password request when running this report.  Try unchecking it and see if that fixes the issue.  Maybe I'm misunderstanding, but I thought you were trying to avoid having the user being prompted for a password each time they run a report.  Unchecking that checkbox does exactly that.
If you key the password in the CMC, it stores the password and passes it to the report/database when someone runs the report.  This saves the user from having to key the pw each time they run the report, and security is handled in CMC, rather than with a password.  
Hope this makes sense.  Give it a try and let me know if it clears your issue.  Thanks.
0
 

Author Comment

by:beargonefishing
ID: 22825038
I had that option checked before and it works just fine. it just grabs the db login info from the report itself and passed it on. i think i might be onto something here though. i had all my machine dsns setup for my odbc connections and just added a fille dsn also for the hell of it. what do you know, one of the reports opened up. i will keep you posted.
0
 

Accepted Solution

by:
beargonefishing earned 0 total points
ID: 22826435
that did it. needed to have the file dsns as well as the machine ones. sometimes the answer is just there slapping you in the face..lol.
0
 

Author Comment

by:beargonefishing
ID: 22867967
Issue was solved by requester
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Data architecture is an important aspect in Software as a Service (SaaS) delivery model. This article is a study on the database of a single-tenant application that could be extended to support multiple tenants. The application is web-based develope…
How to increase the row limit in Jasper Server.
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now