Solved

IIS will not open .asp websites

Posted on 2008-10-28
6
350 Views
Last Modified: 2012-05-05
I am running Server 2003 RC2 with IIS.  3 websites all using .asp.  ASP is enabled and I can view .htm .html etc. if i set it up that way. Default documents are correct but when loading any .asp website I get a http 400 the page cannot be found.  There are no errors in the event log.

Any suggestions?
0
Comment
Question by:Binatech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 8

Expert Comment

by:tony_angelopoulos
ID: 22822180
A few other things I would check:

1)The physical directory with the web site has to have file level permissions (read, write, execute) granted to the IIS accounts on your local machine. (right click on the folder, security, local machine, look up the IIS and ASP accounts, give them these permissions)
2)Make sure the version of ASP you are running is set correctly (1.1 or 2.0)
3)After doing these steps and if still no success, remove the virtual directory and rebuild it, stop and start the IIS service (start->run->services.msc)
0
 
LVL 2

Expert Comment

by:fokuszg
ID: 22822218
by "asp is enabled" you mean Active Server Pages option set to allowed under web service extensions of iis manager?
0
 

Author Comment

by:Binatech
ID: 22822739
fokuszg -> Yes

tony -> I have tried all three options.  No luck

I am going to reinstall IIS and see if I am able to get it working.  Any other suggestions?
0
Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

 
LVL 9

Expert Comment

by:Seven price
ID: 22822897
did you try making it into a virtural directory
0
 

Accepted Solution

by:
Binatech earned 0 total points
ID: 22822927
sevensnake77 -> Yes they were running as virtual directories.


Reinstall of IIS solved the solution.  Original IIS was a fresh install as well.  It is unknown as to what caused the problem but issue resolved never the less.
0
 

Author Comment

by:Binatech
ID: 22822941
Thanks everyone for your help.
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
Lync server 2013 or Skype for business Backup Service Error ID 4049 – After File Share Migration
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question