Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Configuring OSPF with loopback address

Posted on 2008-10-28
8
Medium Priority
?
2,824 Views
Last Modified: 2008-10-28
I'm at it again using the simulator.  I'm trying to configure three routers to talk to each other using OSPF.  Each of these routers have loopback address.  Is this the right way to configure the routers (especially the second router with two interfaces?  (all routers in area 0)  I don't know if the wildcard masks should say exact address or 0.0.255.255 since all the routers are in area 0.  Thank you!

Router1 (IP 192.168.1.1/24, Loop 10.10.10.1/24):
R1(config)#router ospf 1
R1(config-router)#network 192.168.1.1  0.0.0.0 area 0
R1(config)int loopback 0
R1(config)ip address 10.10.10.1 255.255.255.0
no shutdown

Router2 (IP 192.168.1.2 & 192.168.2.2, Loop 172.20.100.1):
R1(config)#router ospf 2
R1(config-router)#network 192.168.1.2  0.0.0.0 area 0
R1(config-router)#network 192.168.2.2  0.0.0.0 area 0
R1(config)int loopback 0
R1(config)ip address 172.20.100.1 255.255.255.0
no shutdown

Router3 (IP 192.168.2.1/24, Loop 172.16.100.1/24):
R3(config)#router ospf 3
R3(config-router)#network 192.168.2.1 0.0.0.0 area 0
R3(config)int loopback 0
R3(oncifg)ip address 172.16.100.1 255.255.255.0
no shutdown
0
Comment
Question by:elly960
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22822220
That will work but if you want to be able to communicate between loopbacks, add them to OSPF as well.

R1(config-router)#network 10.10.10.1 0.0.0.0 area 0

R2(config-router)#network 172.20.100.1 0.0.0.0 area 0

R3(config-router)#network 172.16.100.1 0.0.0.0 area 0
0
 
LVL 23

Expert Comment

by:that1guy15
ID: 22822304
You are right about the wildcard mask. 0.0.255.255 and 0.0.0.0 will both work but 0.0.255.255 will be more efficient.
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 500 total points
ID: 22822409
Better yet, if you want to run OSPF on all interfaces, simply do this:

R1(config)#router ospf 1
R1(config-router)#network 0.0.0.0 255.255.255.255 area 0

R1(config)#router ospf 2
R1(config-router)#network 0.0.0.0 255.255.255.255 area 0

R3(config)#router ospf 3
R3(config-router)#network 0.0.0.0 255.255.255.255 area 0

"0.0.0.0 255.255.255.255" matches all interfaces on the router.
0
ATEN's HDBaseT Presentation at InfoComm 2017

Hear ATEN Product Manager YT Liang review HDBaseT technology, highlighting ATEN’s latest solutions as they relate to real-world applications during her presentation at the HDBaseT booth at InfoComm 2017.

 

Author Comment

by:elly960
ID: 22822861
JFrederick,
Using your idea above, s this correct?

R1:
int g1/0
ip address 192.168.1.1 255.255.255.0
no shutdown
int loopback 0
ip address 10.10.10.1 255.255.255.0
no shutdown
R1(config)#router ospf 1
R1(config-router)#network 0.0.0.0 255.255.255.255 area 0

R2:
int g1/0
ip address 192.168.1.2 255.255.255.0
no shutdown
ing g2/0
ip address 192.168.2.2 255.255.255.0
no shutdown
int loopback 0
ip address 172.20.100.1 255.255.255.0
no shutdown
R2(config)#router ospf 2
R2(config-router)#network 0.0.0.0 255.255.255.255 area 0

R3:
int g1/0
ip address 192.168.2.1 255.255.255.0
no shutdown
int loopback 0
ip address 172.16.100.1 255.255.255.0
no shutdown
R3(config)#router ospf 3
R3(config-router)#network 0.0.0.0 255.255.255.255 area 0
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22822923
Looks good.  All interfaces will run OSPF.
0
 

Author Comment

by:elly960
ID: 22823538
It worked great!  A quick question... when would I use the IP specific wildcard mask instead of 255.255.255.255?
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22823574
Well, this should only be used in instances when you desire running OSPF on "ALL" router interfaces in the "SAME" area.  In a multi-area OSPF setup, this won't work for you since you need to specify different areas per network/interface.
0
 

Author Comment

by:elly960
ID: 22823866
Thank you so much for all your help!
0

Featured Post

[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question