• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1099
  • Last Modified:

How to avoid "search results" all being selected by default?

In Notes 7 Client, I search for a string in my email using View->Search This View - all the documents returned are selected by default. This is not natural behaviour and so when I then do what I want to do, such as move the document to a folder, *all* my returned documents are moved. And since Notes doesn't have an undo function I can't correct the mistake.

Is there any way to stop Notes selecting the documents returned by search?
0
sjm_ee
Asked:
sjm_ee
1 Solution
 
Sjef BosmanGroupware ConsultantCommented:
I've said too often that something isn't possible in Notes and then someone else told me it is... So I'll say that I have never seen such an option, and I have see a lot. I understand what you want, and I can only explain the Notes' way, which is that documents that match the query are selected and shown. If you then click on View/Selected (deselecting Selected actually), you'll see that all documents are shown in the view and the ones you selected are - er... - selected....

So I suppose you have to narrow down your selection, either by deselecting document or by a more restricting selection formula.
0
 
Sjef BosmanGroupware ConsultantCommented:
The option I mentioned is View/Show/Selected Only
0
 
SysExpertCommented:
If you only want one document, then unselecing in the view. should bring back the full view, and you should have the single document highlighted ( not selected ).

I hope this helps !
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
brwwigginsCommented:
Expand the search section by clicking "more"

In the options for "sort results by" try changing it from say "keep current order" to relevance or one of the other options. Off hand I can't remember which one selects them and which does not.
0
 
sjm_eeAuthor Commented:
SysExpert I am not sure I follow - please say again
0
 
Bill-HansonCommented:
Here's how I do it:

First, make sure that the database is full-text indexed.  Searching an unindexed database will always result in the "all checked" problem.  It sounds strange, but the trick is to use the correct sort option.  To change the sort option, use the "More" hotspot (See figures below).

If you select "relevance", "last modified", or "first modified" you will be able to select individual documents in the search results.

If you select either of the "sortable" options ("keep current order" or "show all documents"), then you will still have the "all checked" problem.
SearchBarMore.gif
SearchBarSortBy.gif
0
 
Sjef BosmanGroupware ConsultantCommented:
Maybe you noticed that, when you deselect a document manually, it is removed from the view? So you could, prior to moving the selection to a folder, deseletc the documents that you don't want to be moved to the folder.

IMHO there's no such feature as you describe in Notes. Matching in a view is literally "selecting documents that match certain conditions".
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now