Issue when creating user account with mailbox - "The directory service encountered an unknown error"

Get an error after creating a new user account (with a new mailbox) in active directory.  The error is: "Windows cannot create the object because: The directory service encountered an unknown failure"
If I create a new user account and choose not to create a new mailbox I don't get the error.  If I then right click on the new user account and choose "Exchange Tasks" and select "Create Mailbox" and go throught the wizard I get a failed error.  Here is the XML file:

<?xml version="1.0" encoding="unicode" ?>
- <taskWizardRun taskName="Create Mailbox" dcName="PRIMARY-BDA-1" buildNumber="7638" runningAs="Administrator@primary.bm">
  <timespan startTime="2008-10-28 14:09:37.721" milliseconds="16" />
- <createMailbox>
  <database>/dc=bm/dc=primary/dc=bda/cn=Configuration/cn=Services/cn=Microsoft Exchange/cn=Primary Group Bermuda/cn=Administrative Groups/cn=First Administrative Group/cn=Servers/cn=PRIMARY-BDA-1/cn=InformationStore/cn=First Storage Group/cn=Mailbox Store (PRIMARY-BDA-1)</database>
  </createMailbox>
  <taskSummary errorCount="1" completedCount="0" warningCount="0" errorCode="0x00000000" />
- <items>
- <item adsPath="test1" class="user">
  <progress code="-4" milliseconds="16">Saving changes to the directory</progress>
  <summary isWarning="false" errorCode="0x80072020">An operations error occurred.</summary>
  </item>
  </items>
  </taskWizardRun>

I looked up the error code using the Error Code Lookup Tool and this is what it found:

C:\Documents and Settings\SLawrence\Desktop\Err>err 0x80072020
# as an HRESULT: Severity: FAILURE (1), Facility: 0x7, Code 0x2020
# for hex 0x2020 / decimal 8224 :
  ERROR_DS_OPERATIONS_ERROR                                     winerror.h
# An operations error occurred.
# 1 matches found for "0x80072020"

I also just noticed a repeating error in my event viewer, although I'm not sure it's related to the issue above.
Source: NTDS ISAM
Category: Database Page Cache
Event ID: 476
GSLBermudaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

robrandonCommented:
The Database Page Cache error may push you to run ESEUTIL and ISINTEG on your databases.  Are there any other messages in the event log?

What account and computer are you using when you are trying to mail enable the mailbox?  
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
GSLBermudaAuthor Commented:
The environment only has two servers - PDC and BDC and I tried on both of them logged in as Administrator (NOTE: I checked to make sure that Administrator is member of all the correct groups)
I'll have to get back to you on if their are any other messages in the event log.
0
robrandonCommented:
Is this an NT4.0 domain?

Try creating an account using ADUC on your Exchange server and see if you get an error.

If it works there but not on other computers, make sure the other computers have the same SP/hotfix level as Exchange, as the Exchange tools need to be the same level of the Exchange Server.

0
GSLBermudaAuthor Commented:
OK...........So I was wrong when I stated that there is a PDC and BDC.  There is only one DC (also has exchange and SQL 2005 installed on it) and the second server is just an app\file\etc. server.  I did some more research and I think the NTDS.dit file has become corrupt.  The event ID 476 has been poping up since June and says that NTDS.dit is corrupt from possible failed hardware.
If repairing the NTDS.dit file in directory restore mode doesn't work, that maybe I should promote the other server as a DC, move FSMO roles, etc. and then demote the first server.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.