Solved

Cannot Connect To Printer Across The LAN

Posted on 2008-10-28
10
628 Views
Last Modified: 2013-12-15
I have installed an HP Deskjet 3930 printer on a classroom pc. I have shared it for everyone to use.
I can print from the local pc. When trying to add it to another computer as a network printer, it first asks for a username and password. It will not accept anything I enter as valid. Even Domain Admin.
It then times out and says it is not accessible. This printer used to be attached to a laptop in the server room. When one of the teachers printers broke, I gave her this one and bought a new one for myself. It worked fine when it was mine and I could access the share from anywhere.
Unless it is broken in some weird way, I am at a loss as to why it will not connect.
One other thing. Is is possible that somewhere their is a record of this being attached to my laptop, and that record is causing problems when trying to access it?
 I have tried this printer on 2 different PCs. Same problem each time. The printer was installed as the local admin on the computer. Then I logged in as the classroom and tried to connect, but no go. I even tried it from my pc. Notta. Please advise. Thanks.
0
Comment
Question by:gpfrank
  • 6
  • 2
  • 2
10 Comments
 
LVL 1

Accepted Solution

by:
rexifelis earned 250 total points
ID: 22824998
have you tried setting up the printer as the same user on both machines?  that is administrator with both passwords being identical?  usually printer sharing hangs on the user/pass like you said in your post.  and check the security settings on the printer and make sure that the user you are setting up for printer access has full permissions for that printer.
if after this something is still preventing access via:
\\machinename\printername
you should be able to get access via:
\\192.168.0.2\printername    (of course the 192.... being the shared computer's ip address)
0
 

Author Comment

by:gpfrank
ID: 22825387
The users have the proper rights, username and password match. I cannot even connect via IP Printing.
I get an "unknown device" message. I think this printer is broken. Never saw anything like it.
0
 
LVL 1

Expert Comment

by:rexifelis
ID: 22825545
well... if the printer in question can be printed to by the computer it is attached to it is *not* the printer... it *has* to be software.  
are you in a protected environment?  as in a firewall/NAT blocking your machines from outside access?  can you turn off the windows firewall? (this may or may not have any bearing on this problem).
have you tried using HP's drivers and not the compatibility drivers (the ones built into windows) ??
http://h10025.www1.hp.com/ewfrf/wc/softwareList?os=228&lc=en&dlc=en&cc=us&lang=en&product=445446
here is the link to HP's 3930 driver page...
0
 
LVL 1

Expert Comment

by:sardaukarz
ID: 22825675
OK I didn't go on Hp page to check settings for the 3930 but it is obvious this is a personal printer and it is not suited for a work environnement. You probably use it to print small work docs but nothing fancy.

I also assume there is no network card in this printer that is the reason why you plug it on a PC and share it. I also assume you prug it USB??? And here I gotta stop cause I always had problems printing on a USB shared printer over the nework. I have one home and I always had problems printing from my second pc on the USB connected printer (installed and shared on my first Windows PC). As soon as I plugged the printer with a parallel cable no more weird problems.

Also as rexifelis was suggesting be sure to us HP drivers instead of the Microsoft Windows provided drivers. ALWAYS!!! For any printer whatsoever.

You also talk about Domain Admin. Are this computers part of a domain? Please answer our questions so we can help you with further ideas.

Thanks

Sardaukarz

0
 

Author Comment

by:gpfrank
ID: 22839456
Yes it is in a Domain enviroment. It is connected usb. I had this printer working on another pc AND shared . And I could access it from anywhere as a shared printer. When I put it in this particular classroom is when the problems started. It will print from the computer it is connected to. BUT you cannot connect to it from any other computer.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 1

Assisted Solution

by:sardaukarz
sardaukarz earned 250 total points
ID: 22842386
OK stupid question : do you ping the computer witch shares the printer from the other computers? Is your classroom in another VLAN or something? Maybe classrooms are configured on other VLANS in order to limit connectivity to and from. We use this at my work.

One other thing please try a parallel cable if possible. Just to be sure. Check also settings on new host computer for the firewall, check anti-virus settings and all other program witch might block ports.

As you stated before this printer was installed on your pc witch is a power user/administrators pc and the classroom pc is probably under another set of GPOs and so on (maybe I don't know how you do configure your AD and or network).

Also, is the printer published in Active Directory? Go to printer settings there is a little check box publish this printer in AD (or some other name with same meaning).

Post some results. Thanks
0
 

Author Comment

by:gpfrank
ID: 22850674
No vlans. One network ip range. USB connection only. I am going to move the printer back to my laptop.
Then see if it still can be shared and accessed. The strange thing is that I installed it as the local admin of that pc. And shared it that way. I have several deskjets shared this way and all are functioning well. I will try moving it to another container/computer with more rights and see what that does. Maybe it is a rights thing.
0
 

Author Comment

by:gpfrank
ID: 22923468
OK, I installed it on my laptop and listed it in the directory. Then I went to my desktop and added it easily as a network printer.
Next, I will reinstall it in the room it was in.
I think I may have found the problem. I will elaborate  after the next installation.
0
 

Author Comment

by:gpfrank
ID: 22924875
Problem is solved. I installed the printer on another pc in the same room. The problem was that the dhcp server was not automatically resolving the names with an accurate ip address. I set it to auto update and now I can print. I actually stumbled across the problem while updating my Panda Admin Secure software. Many of the machines would not update by name. I had to use the ip address. When I checked the name against the ip I found that they did not match on some of my machines. So I went looking for the problem. The printer problem actually uncovered a dhcp/dns problem. I hope that this resolves some other issues that I was having as well.
I will split the points evenly. Thank you for your help and ideas.
0
 

Author Closing Comment

by:gpfrank
ID: 31510888
Thanks again!
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Causes of paper jams:The following are the main causes of paper jams. Guides:If the guides for the paper are not set correctly they may cause the paper to enter at an angle. You should ensure that the guides are set correctly for the paper type a…
For both online and offline retail, the cross-channel business is the most recent pattern in the B2C trade space.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now