IE 7 won't play SWF files

I am trying to play a SWF file in IE7(XP SP3) from the locat C drive. I enter c:\test\.swf into IE7, the progress bar at the bottom goes white for a second or two but when it is finished IE7 only displays a white page. This same file plays properly in Firefox and Safari. I have uninstalled Flash player and reinstalled it but the results are the same. Any ideas what settings I need to change?
thanks,
pat
mpdillonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jazzIIIloveCommented:
Hi there,

Have you uninstalled / reinstalled your IE flash?
What about shockwave? install/uninstall process?

or use the follo1wing:

manually uninstall the ActiveX control
Quit Internet Explorer, if it is open.
From the Start menu, choose Search> Files or Folders and search for flash.ocx (if you are removing Macromedia Flash Player 6) or swflash.ocx (if you are removing Macromedia Flash Player 5 or earlier).

Note: The name of the ActiveX control changed with version 6 to "flash.ocx". See Windows XP error installing Macromedia Flash Player ActiveX control (TechNote 16178) for details.

Note the path to the file. The path is typically:
C:\Windows\System\Macromed\Flash on Windows 95, 98 or WinME;
C:\WinNT\System32\Macromed\Flash on Windows NT or 2000;
C:\Windows\System32\Macromed\Flash on Windows XP.

If more than one copy of the file is found, note the paths to all copies of the file.
Select Start> Run.
In the Open field, enter the following command:

regsvr32 {path} \ {filename} /u

Replace {path} with the path to the filename noted from step 3.
Replace {filename} with the filename noted from step 2.

For example, if you're uninstalling the Macromedia Flash Player 6 ActiveX control on Windows 2000, the path would be:

regsvr32 C:\WinNT\System32\Macromed\Flash\flash.ocx /u
Click OK. You should get a RegSvr32 dialog box stating that the executable succeeded. If it failed, double check the path and file name for your system.
Select Start> Find Files or Folders and enter flash.ocx (if you are removing Macromedia Flash Player 6) or swflash.ocx (if you are removing Macromedia Flash Player 5).
Right-click on the found file and choose Delete from the context (right-click) menu. If more than one copy of the file exists, delete each one.
Search for swflash.inf using Windows Find utility (Start > Find > Files or Folders). This file is used during the installation of the Macromedia Flash Player ActiveX control.
Right-click on the file and choose Delete.
Restart the machine.

Best regards...
0
jcimarronCommented:
mpdillon--Concerning c:\test\.swf see here
http://www.experts-exchange.com/Programming/Languages/C_Sharp/Q_20608026.html
Maybe do not worry about that test.
But your main concern probably is to play .swf files.  What happens if you just click to play the .swf file? Error messages?
You can  test your Flash and Shockwave installations here
http://www.adobe.com/shockwave/welcome/
Do you have the latest?  Flash is up to v10 and Shockwave is up to v11.
Is this something new?  If so you could try a System Restore to a date prior to the problem starting.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Gyanendra SinghArchitectCommented:
Try toggling the option

Allow active content to run on files in My Computer*

(in Options, Advanced tab, Security section)

Note that the asterisk means that a restart of  IExplore.exe  is required
before any testing of the new setting will be valid.

FWIW  no  .swf  files work either locally or via direct URL for me
unless that option is  _unchecked_.    This seems backwards
to me according to the label of the option but seems to make
a bit more sense under the covers in relation to a ControlFeature
called  LocalMachine_LockDown.
0
jazzIIIloveCommented:
jcimarron has the right start...After that BondinASP...Mine may be later than my friends...

Best regards...
0
mpdillonAuthor Commented:
Going to the adobe.com/shockwave/welcome page fixed the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.