Win2k3 R2 SP2: Cannot Install Anything

The OS is fully patched.
Logging in with Domain Admin account
DEP is turned to lowest setting (essential Windows processes only)
Nothing of note in any of the logs
DNS entries look good
Deleted and recreated profiles
nltest reports secure channel is good
Firewall, antivirus disabled for testing

There were no issues setting up the server that I'm aware of (it was a multi-shift project), but now that the server is fully installed and patched I'm unable to run any exe's.  If the .exe is on another machine I'm able to browse to it, but attempting to execute an installer gets an error:

"Windows cannot access the specified device, path of file.  You may not have appropriate permissions to access the item."

The "item" exists, and I can run it when logged into another server.  If the exe is local the same error occurs.  Two other domain admins have had the same result.

I'm out of ideas.  Anyone?

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

If you create a new account and add it to the Domain & Enterprise admin groups can you execute the program locally?
Raymond JansenCommented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
roberts0909Author Commented:
Found it.  

Right-click the item and unblock it.  Who'da thought of this?
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

roberts0909Author Commented:
Well, partly found it.

Under the General tab there is a Security section.  "This file came from another computer and might be blocked to help protect this computer:  There is an option at the bottom to Unblock, but it only let me install that one utility.  I'm still having trouble with anything over a network share or UNC.  
Check out the last post in this thread:
roberts0909Author Commented:
Now I see that I can 'unblock' some programs' installers and not others.   Maybe it's if they have a similar name and that file name has been unblocked before.

Actually, here is another post about it. This will be relevant even if you aren't using Vista.
roberts0909Author Commented:
I should have read the entire post that r-jansen put up.  It appears to be the IE trusted sites.  I'll continue to test...

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.