NoActiveDesktop under LOCAL_MACHINE gets reset to value of 1 after reboot. If NoActiveDesktop key under LOCAL_MACHINE is deleted, it is recreated and assigned a value of 1.

I can no longer see any jpegs for Desktop Backgrounds under the Desktop Tab of Display Properties and the Web Tab is missing under Desktop Items.  
These are the current entries from the Registry.  

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091
"NoSaveSettings"=dword:00000000
"ClassicShell"=dword:00000000
"NoActiveDesktop"=dword:00000000

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoActiveDesktop"=dword:00000001

If I change NoActiveDesktop to 0 under LOCAL_MACHINE, I can see jpegs under the Desktop Tab and the Web Tab reappears.  But if I reboot, the value gets reset to 1.
If I delete the NoActiveDesktop key under LOCAL_MACHINE, again I can see jpegs under the Desktop Tab and the Web Tab reappears. But if I reboot, the NoActiveDesktop key under LOCAL_MACHINE gets re-created with a value 1.  And, I'm back to where I was not being able to see any JPEGS for desktop backgrounds under the Desktop Tab.
AndeAsked:
Who is Participating?
 
AndeConnect With a Mentor Author Commented:
Sorry for the delay, had a family crisis.  I did however discover the problem.  

I've been accessing this computer with LogMeIn remote access.  I knew that LogMeIn removes the background wallpaper when you connect to improve speed, but I didn't realize how it accomplished this.  Apparently it uses the NoActiveDesktop Key.  This is why the key was recreated even after I had deleted it in the registry.  Once the LogMeIn remote session terminated, the NoActiveDesktop returned to a value of '0' and the jpeg wallpapers were visible again.  There is a setting in the LogMeIn Preferences that disables this behavior so that the wallpaper shows up when remotely connected.

Thanks so much for your advice.  And, sorry I didn't figure this out sooner.
0
 
orangutangCommented:
Do you think it could be virus related? Send us your HijackThis (http://www.trendsecure.com/portal/en-US/threat_analytics/hijackthis.php) log. Also, try FixPolicies (http://downloads.malwareremoval.com/BillCastner/FixPolicies.exe). Also, do you think it could be a GPO?
0
 
flubbsterCommented:
yeah... it just may be a group policy thing. You may or may not have the rights to change it. To check though, do the following:

click on start>run
type "gpedit.msc"  (no quotes)  and hit enter
navigate to the following:

User Configuration\AdministrativeTemplates\Desktop\Active Desktop\

double-click on Enable Active Desktop and then place a check in "Enable"

click apply to back out and reboot. Go back and check the settings now.

good luck..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.