Server status reports not getting sent

I have a SBS 2003 box that for some reasoon will not send status reports.
I have tried reruning the "server monitoring and reporting setup"
I have checked the settings for the monitoring and reporting. ie email address, account sent from...
When i try to send a test report i get this error " An error occurred while sending the Server Status Report. Verify that report configuration settings are correct, and then try again"
Ive checked the logs and the only error i can find is this one below:
Event Type:	Error
Event Source:	ServerStatusReports
Event Category:	None
Event ID:	1
Date:		29/10/2008
Time:		10:55:49
User:		N/A
Computer:	SERVER1
Description:
Server Status Report:
	URL:		http://localhost/monitoring/perf.aspx?reportMode=1&allHours=1
	Error Message:	General network error.  Check your network documentation.
	Stack Trace:	   at usage.globalFn.connectDataSource(Boolean pingFirst)
   at usage.frmPerf.renderReportWorker()
   at usage.frmPerf.renderReport()
 
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Open in new window

vehastingsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gratex_ssdCommented:
This looks like .net framework error. Check that .NET 2.0 is not selected on default website properties in the .NET tab, in IIS. If it is, set it to 1.4 and see if it helps.
0
gratex_ssdCommented:
Sorry, typo not 1.4 but 1.1.4
0
vehastingsAuthor Commented:
Hi
I do not have a APS.NET tab in my IIS > defualt website properties.....
I only have ASP.NET v 1.1.4322 installed.
any other ideas?
thanks
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

gratex_ssdCommented:
Try to follow this guide about same problem you're encountering

http://www.eggheadcafe.com/forumarchives/windowsserversbs/Oct2005/post24693836.asp
0
vehastingsAuthor Commented:
I have looked at your idea above and i have not got any problems with the reports themselves.... i can see them on the server. BUT it will not send them.
So to recap..
I can set up reports fine.
I can view reports fine
i get a email notification saying that i have set up reports.
But when i go to send the report i get the following error
" An error occurred while sending the Server Status Report. Verify that report configuration settings are correct, and then try again"
0
gratex_ssdCommented:

From where you're trying to sent the report and get that error message?  From the console's "Change Server Status Report Settings"?

Try to reboot your server when you have chance and see what it does.
0
vehastingsAuthor Commented:
Hi I have restarted the server today and there has been no change to the problem.
0
gratex_ssdCommented:
Alright, check this: (courtesy SBS DIVA http://forums.techarena.in/small-business-server/1055598.htm)

Go to IIS, Default Web Site, Web Site tab, Advanced. Verify the IP address
Default does not have a host header. Removed any host header assiged to
Default.
If you have to assign a host header to the default website, please add
127.0.0.1 with port 80 and NO host header to the default website.


NOTE: Monitoring and Reporting, and Backup snapin in Server Management
communicate with the IIS Default Website using 127.0.0.1. Make sure
127.0.0.1 port 80 is availalbe and no host header is assigned to 127.0.0.1.
0
vehastingsAuthor Commented:
Hi I checked out the link but didn't help me much. thanks thou.
I have checked the IIS settings - there was not a host header assigned.
0
gratex_ssdCommented:
Alright. Please do answer me my previous questions to be able to assist you further:

From where you're trying to sent the report and get that error message?

Do you indeed have 127.0.0.1 specified on Default Website?

Thanks
0
gratex_ssdCommented:
0
vehastingsAuthor Commented:
Hi thanks for all your helps guys.
I decided to go to microsoft in the end as i wasn't getting anywhere.
Here is the solution!

Go to> IIS > Server > websites > default website properties.
Home directory tab > Check the local path
Should be:
C:\inetpub\wwwroot         (mine was c:\inetpub - so just changed it and it worked!!!! )
Apply
Try to resend the report.

All working happy days!.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vehastingsAuthor Commented:
all fixed
0
CmcDoITOCommented:
There's a more universal solution that I came around while having the same problem.
After hours of debugging, checking permissins and folder contents, I fired up ProcMon
to find out what's happening, and... BINGO! The 'mssbsssr.exe' program that is used
for sending the reports seems to have a hardcoded lookup for a directory called
"Monitoring" at the same level as the root directory of your default website, i.e.
calling something like "..\Monitoring"

The solution is so simple and astonishing that it can't be found anywhere yet:
Just copy the whole C:\INetPub\Monitoring directory to the path where your
default website root resides, i.e. if your web root is D:\INetPub\Default,
copy it to D:\INetPub\Monitoring. That's it, your reports get sent again! :-)

Of course you could also move the folder, but I would suggest leaving it there,
just in case a patch or service pack touches it and would not find it then.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.